Bug 884715 - FTBFS: build on PPC(32bit) gets stuck in factor tests
FTBFS: build on PPC(32bit) gets stuck in factor tests
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
rawhide
ppc Linux
medium Severity high
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-06 10:52 EST by Karsten Hopp
Modified: 2012-12-06 11:13 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-06 11:13:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2012-12-06 10:52:37 EST
Description of problem:
coreutils-8.20 gets stuck forever in the self checks on 32bit PPC.

I've set up a F19 chroot and it looks like factor gets stuck every time a number is dividable by 2. (^C marks when I had to abort a command)

bash-4.2# ./factor 1
1:
bash-4.2# ./factor 2
^C
bash-4.2# ./factor 3
3: 3
bash-4.2# ./factor 4
^C
bash-4.2# ./factor 5
5: 5
bash-4.2# ./factor 6
^C
bash-4.2# ./factor 7
7: 7
bash-4.2# ./factor 8
^C
bash-4.2# ./factor 9
9: 3 3
bash-4.2# ./factor 10
^C
bash-4.2# ./factor 11
11: 11
bash-4.2# ./factor 12
^C
bash-4.2# ./factor 13
13: 13
bash-4.2# ./factor 14
^C
bash-4.2# ./factor 15
15: 3 5
bash-4.2# ./factor 16
^C




Version-Release number of selected component (if applicable):
8.17 worked, all releases of 8.20 fail

How reproducible:
always

Steps to Reproduce:
1. ppc-koji build --scratch f19 coreutils-8.20-2.fc19.src.rpm
or
1. create a F19 PPC chroot, rebuild coreutils-8.20 in it
2. run the newly built factor binary with different values
3.
  
Actual results:
koji task needs to be aborted, see p.e. 
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=807977

Expected results:
hagen:[~] >factor 1
1:
hagen:[~] >factor 2
2: 2
hagen:[~] >factor 3
3: 3
hagen:[~] >factor 4
4: 2 2
hagen:[~] >factor 5
5: 5
hagen:[~] >factor 6
6: 2 3
hagen:[~] >factor 7
7: 7
hagen:[~] >factor 8
8: 2 2 2


Additional info:

Note You need to log in before you can comment on or make changes to this bug.