Bug 884743 - Change ja-JP folder to ja
Change ja-JP folder to ja
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhevm-doc (Show other bugs)
3.1.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.2.0
Assigned To: Kiril Nesenko
Lijun Li
: i18n, Rebase, Reopened, ZStream
Depends On:
Blocks: 870028 884289
  Show dependency treegraph
 
Reported: 2012-12-06 11:23 EST by Stephen Gordon
Modified: 2014-07-10 20:09 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
: 885137 (view as bug list)
Environment:
Last Closed: 2013-06-10 16:17:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stephen Gordon 2012-12-06 11:23:37 EST
Description of problem:

The UI logic for context sensitive help looks for the 'ja' locale when building the link. While this is a valid locale in Zanata it is not a valid locale in XML, and therefore the tools that build the documentation, they instead use ja-JP.

The end result of this is that context sensitive help doesn't work at all in Japanese because the UI goes looking for content (or fallback links) in the '/usr/share/ovirt-engine/docs/ja' folder when it actually resides in '/usr/share/ovirt-engine/ja-JP'.

To fix this:

1) Either the UI needs to be updated to point at the 'ja-JP' folder.

-or-

2) The rhevm-doc-ja-JP update needs to change the folder for 'ja-JP' to 'ja'.

My preference is actually for (2) because:

- This build is already a rebase (and already required, it was supposed to be 0-day).
- It fixes another issue I had as a result of the fallbacks we used in the original build (see Bug # 884289 for the ugly details).
Comment 1 Stephen Gordon 2012-12-06 11:26:15 EST
Discussed with Einav and preference is also for option (2). Einav to discuss with Manuel about ensuring UI and Documentation locales are aligned for future language packs we might want to add.
Comment 3 Stephen Gordon 2012-12-06 12:49:25 EST
(In reply to comment #1)
> Discussed with Einav and preference is also for option (2). Einav to discuss
> with Manuel about ensuring UI and Documentation locales are aligned for
> future language packs we might want to add.

Have confirmed with a scratch build that this works, it installs both cleanly and as an update and results in the context sensitive help working when I'm logged in using the Japanese (ja) locale.
Comment 5 Stephen Gordon 2013-02-28 09:29:41 EST
Cancel that, this never got applied to the rhevm-3-rhel-6 branch, only rhevm-3.1-rhel-6.
Comment 12 Stephen Gordon 2013-05-06 09:52:57 EDT
The common and RedHat folders contain CSS and image files from the common and RedHat "brands". These files are referred to from the HTML documentation.

Unless you are performing manipulation of the HTML itself or are sure that you are handling this case in the servlet these particular symlinks will still be required (and potentially for other locales?).
Comment 14 Lijun Li 2013-05-23 03:56:59 EDT
Verified, it's fixed on latest sf17.1 build.

[root@rhevm32 manual]# rpm -q rhevm rhevm-doc rhevm-doc-ja-JP
rhevm-3.2.0-11.28.el6ev.noarch
rhevm-doc-3.2.0-2.el6eng.noarch
rhevm-doc-ja-JP-3.2.0-0.1.rc.el6eng.noarch
[root@rhevm32 manual]# pwd
/usr/share/doc/ovirt-engine/manual
[root@rhevm32 manual]# ls -l
total 36
drwxr-xr-x. 3 root root  4096 May 23 03:29 common
-rw-r--r--. 1 root root 16197 May 21 01:36 DocumentationPath.csv
drwxr-xr-x. 4 root root  4096 May 23 02:34 en-US
drwxr-xr-x. 4 root root  4096 May 23 03:29 ja-JP
drwxr-xr-x. 3 root root  4096 May 23 03:29 RedHat
-rw-r--r--. 1 root root  2893 May 21 01:36 UserPortalDocumentationPath.csv
[root@rhevm32 manual]# ls -l RedHat/ common/
common/:
total 4
drwxr-xr-x. 4 root root 4096 May 23 02:34 en-US
lrwxrwxrwx. 1 root root    5 May 23 03:29 ja-JP -> en-US

RedHat/:
total 4
drwxr-xr-x. 4 root root 4096 May 23 02:34 en-US
lrwxrwxrwx. 1 root root    5 May 23 03:29 ja-JP -> en-US

Moving to VERIFIED.
Comment 15 errata-xmlrpc 2013-06-10 16:17:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0916.html

Note You need to log in before you can comment on or make changes to this bug.