Bug 885333 - SELinux is preventing /home/Rob/Steam/ubuntu12_32/steam from using the 'execheap' accesses on a process.
Summary: SELinux is preventing /home/Rob/Steam/ubuntu12_32/steam from using the 'exech...
Keywords:
Status: CLOSED DUPLICATE of bug 877549
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 17
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:96af452d35f844e4d22f755064c...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-08 17:56 UTC by Rob
Modified: 2012-12-10 09:25 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-10 09:25:05 UTC
Type: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-12-08 17:56 UTC, Rob
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-12-08 17:56 UTC, Rob
no flags Details

Description Rob 2012-12-08 17:56:48 UTC
Description of problem:
Running the Linux steam beta and attempting to start "Big picture" mode

Additional info:
libreport version: 2.0.18
kernel:         3.6.9-2.fc17.x86_64

description:
:SELinux is preventing /home/Rob/Steam/ubuntu12_32/steam from using the 'execheap' accesses on a process.
:
:*****  Plugin allow_execheap (53.1 confidence) suggests  *********************
:
:If you do not think /home/Rob/Steam/ubuntu12_32/steam should need to map heap memory that is both writable and executable.
:Then you need to report a bug. This is a potentially dangerous access.
:Do
:contact your security administrator and report this issue.
:
:*****  Plugin catchall_boolean (42.6 confidence) suggests  *******************
:
:If you want to allow_execheap
:Then you must tell SELinux about this by enabling the 'allow_execheap' boolean.You can read 'unconfined_selinux' man page for more details.
:Do
:setsebool -P allow_execheap 1
:
:*****  Plugin catchall (5.76 confidence) suggests  ***************************
:
:If you believe that steam should be allowed execheap access on processes labeled unconfined_t by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep MainThrd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
:                              023
:Target Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
:                              023
:Target Objects                 [ process ]
:Source                        MainThrd
:Source Path                   /home/Rob/Steam/ubuntu12_32/steam
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-161.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.9-2.fc17.x86_64 #1 SMP Tue Dec
:                              4 13:26:04 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    2012-12-08 17:48:11 GMT
:Last Seen                     2012-12-08 17:48:11 GMT
:Local ID                      2905b1d9-6f83-49e2-ba75-9d425b45aa8e
:
:Raw Audit Messages
:type=AVC msg=audit(1354988891.713:94): avc:  denied  { execheap } for  pid=2612 comm="MainThrd" scontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=process
:
:
:type=SYSCALL msg=audit(1354988891.713:94): arch=i386 syscall=capget success=no exit=EACCES a0=d14d000 a1=c000 a2=7 a3=ffc1481c items=0 ppid=2566 pid=2612 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=pts0 ses=2 comm=MainThrd exe=/home/Rob/Steam/ubuntu12_32/steam subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 key=(null)
:
:Hash: MainThrd,unconfined_t,unconfined_t,process,execheap
:
:audit2allow
:
:#============= unconfined_t ==============
:#!!!! This avc can be allowed using the boolean 'allow_execheap'
:
:allow unconfined_t self:process execheap;
:
:audit2allow -R
:
:#============= unconfined_t ==============
:#!!!! This avc can be allowed using the boolean 'allow_execheap'
:
:allow unconfined_t self:process execheap;
:


Potential duplicate bug: 877549

Comment 1 Rob 2012-12-08 17:56:52 UTC
Created attachment 659920 [details]
File: type

Comment 2 Rob 2012-12-08 17:56:54 UTC
Created attachment 659921 [details]
File: hashmarkername

Comment 3 Miroslav Grepl 2012-12-10 09:25:05 UTC

*** This bug has been marked as a duplicate of bug 877549 ***


Note You need to log in before you can comment on or make changes to this bug.