Bug 885334 - [abrt] tigervnc-1.1.0-6.1.fc17: exit: Process /usr/bin/vncviewer was killed by signal 6 (SIGABRT)
[abrt] tigervnc-1.1.0-6.1.fc17: exit: Process /usr/bin/vncviewer was killed b...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
abrt_hash:c4c0fbfce288c55783ec1ca1e8c...
:
: 886839 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-08 12:57 EST by Emmett Culley
Modified: 2013-04-30 19:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-12 14:44:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: environ (1.83 KB, text/plain)
2012-12-08 12:57 EST, Emmett Culley
no flags Details
File: limits (1.29 KB, text/plain)
2012-12-08 12:57 EST, Emmett Culley
no flags Details
File: backtrace (82.06 KB, text/plain)
2012-12-08 12:57 EST, Emmett Culley
no flags Details
File: cgroup (129 bytes, text/plain)
2012-12-08 12:57 EST, Emmett Culley
no flags Details
File: smolt_data (3.18 KB, text/plain)
2012-12-08 12:57 EST, Emmett Culley
no flags Details
File: executable (18 bytes, text/plain)
2012-12-08 12:57 EST, Emmett Culley
no flags Details
File: maps (11.65 KB, text/plain)
2012-12-08 12:57 EST, Emmett Culley
no flags Details
File: proc_pid_status (988 bytes, text/plain)
2012-12-08 12:57 EST, Emmett Culley
no flags Details
File: open_fds (238 bytes, text/plain)
2012-12-08 12:57 EST, Emmett Culley
no flags Details

  None (edit)
Description Emmett Culley 2012-12-08 12:57:44 EST
Description of problem:
This happend while I was not at my workstation.  The viewer was connected to a local machine via that machines Xvnc server.  So I was connected to that users desktop.

Version-Release number of selected component:
tigervnc-1.1.0-6.1.fc17

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
backtrace_rating: 4
cmdline:        /usr/bin/vncviewer d1:0
crash_function: exit
kernel:         3.6.7-4.fc17.x86_64

truncated backtrace:
:Thread no. 1 (7 frames)
: #13 exit at exit.c:100
: #14 CleanupSignalHandler at vncviewer.cxx:144
: #16 __select_nocancel at ../sysdeps/unix/syscall-template.S:82
: #17 CConn::blockCallback at CConn.cxx:214
: #18 rdr::FdInStream::readWithTimeoutOrCallback at FdInStream.cxx:239
: #19 rdr::FdInStream::overrun at FdInStream.cxx:154
: #20 check at ../../common/rdr/InStream.h:48
Comment 1 Emmett Culley 2012-12-08 12:57:46 EST
Created attachment 659922 [details]
File: environ
Comment 2 Emmett Culley 2012-12-08 12:57:48 EST
Created attachment 659923 [details]
File: limits
Comment 3 Emmett Culley 2012-12-08 12:57:49 EST
Created attachment 659924 [details]
File: backtrace
Comment 4 Emmett Culley 2012-12-08 12:57:51 EST
Created attachment 659925 [details]
File: cgroup
Comment 5 Emmett Culley 2012-12-08 12:57:52 EST
Created attachment 659926 [details]
File: smolt_data
Comment 6 Emmett Culley 2012-12-08 12:57:54 EST
Created attachment 659927 [details]
File: executable
Comment 7 Emmett Culley 2012-12-08 12:57:55 EST
Created attachment 659928 [details]
File: maps
Comment 8 Emmett Culley 2012-12-08 12:57:56 EST
Created attachment 659929 [details]
File: proc_pid_status
Comment 9 Emmett Culley 2012-12-08 12:57:58 EST
Created attachment 659930 [details]
File: open_fds
Comment 10 Adam Tkac 2012-12-20 06:11:22 EST
*** Bug 886839 has been marked as a duplicate of this bug. ***
Comment 11 Adam Tkac 2013-03-12 14:44:08 EDT
Since tigervnc viewer was completely rewritten in Fedora 18 and code which caused this crash is no longer present in viewer, I'm closing this bug. Please upgrade to F18.

Note You need to log in before you can comment on or make changes to this bug.