Bug 885373 - PRD32 - test and enable i18n for VM fields residing in the OVF
PRD32 - test and enable i18n for VM fields residing in the OVF
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.2.0
Assigned To: Daniel Erez
Lijun Li
storage
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-08 17:48 EST by Itamar Heim
Modified: 2016-02-10 15:24 EST (History)
12 users (show)

See Also:
Fixed In Version: SF6
Doc Type: Bug Fix
Doc Text:
RHEV now supports the usage of unicode in VM name / Template name / Disk Alias / Snapshot descritpion
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Fixed VM Name and Description (157.88 KB, image/png)
2013-02-27 04:18 EST, Lijun Li
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 10472 None None None Never
oVirt gerrit 10473 None None None Never
oVirt gerrit 10474 None None None Never
oVirt gerrit 10563 None None None Never

  None (edit)
Description Itamar Heim 2012-12-08 17:48:43 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Haim 2012-12-17 03:26:54 EST
Itamar, can you please add some information regarding this PRD? do we have a wiki page for it ? we cannot progress with test plan at this point.
Comment 2 Yaniv Kaul 2012-12-17 03:27:37 EST
Moving QA contact to i18n team.
Comment 3 Lijun Li 2012-12-17 03:45:22 EST
+1
Please provide more info for this PRD, so that i18n QE team can get to know and do further review and qa_ack process.

Thanks,
Robert
Comment 5 Ayal Baron 2012-12-27 09:40:41 EST
Looks like with the addition of a simple patch to fix passing utf strings to vdsm and removal of limitations this works.
Comment 7 Daniel Erez 2013-01-06 12:24:19 EST
patches merged:
http://gerrit.ovirt.org/#/c/10472/
http://gerrit.ovirt.org/#/c/10473/
http://gerrit.ovirt.org/#/c/10474/
http://gerrit.ovirt.org/#/c/10563/

note: network name is still validated using non-Unicode alphanumeric regex:
^[_a-zA-Z0-9]{1,15}$ (since network name is used for bridge name).
Comment 8 Lijun Li 2013-02-24 22:36:55 EST
Hi Itamar Heim,

Could you please provide the reproduced steps for how to verify the bug?

Thanks,
Robert
Comment 9 Lijun Li 2013-02-25 04:47:29 EST
Hi Daniel Erez,

Could you please provide the reproduced steps for how to verify the bug?

Thanks,
Robert
Comment 10 Daniel Erez 2013-02-25 14:43:47 EST
(In reply to comment #9)
> Hi Daniel Erez,
> 
> Could you please provide the reproduced steps for how to verify the bug?
> 
> Thanks,
> Robert


Hi Robert,

Verification should consist of the following:

* Test that VM name / Template name / Disk Alias
  can contain Unicode characters and/or ._- characters
  (and cannot contain special characters).
  I.e. these attributes should conform to "^[\\p{L}0-9._-]+$" regex.

* Test that VM / Template / Snapshot descritpion
  can contain Unicode characters and/or ASCII characters.
  I.e. these attributes should conform to "[\\p{ASCII}\\p{L}]*" regex.
Comment 11 Lijun Li 2013-02-27 04:15:20 EST
Verified. It's fixed on RHEVM3.2 latest sf build(sf8).

# rpm -q rhevm rhevm-webadmin-portal
rhevm-3.2.0-9.el6ev.noarch
rhevm-webadmin-portal-3.2.0-9.el6ev.noarch


Please see the attached screenshot.
Comment 12 Lijun Li 2013-02-27 04:18:40 EST
Created attachment 703321 [details]
Fixed VM Name and Description
Comment 14 Itamar Heim 2013-06-11 04:40:42 EDT
3.2 has been released
Comment 15 Itamar Heim 2013-06-11 04:40:42 EDT
3.2 has been released
Comment 16 Itamar Heim 2013-06-11 04:40:50 EDT
3.2 has been released
Comment 17 Itamar Heim 2013-06-11 04:48:13 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.