Bug 88552 - cdrecord produces errors/failures
Summary: cdrecord produces errors/failures
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cdrecord   
(Show other bugs)
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-10 20:29 UTC by Michael Knepher
Modified: 2007-04-18 16:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-06 17:07:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output for cdrecord generated using k3b front-end (7.12 KB, text/plain)
2003-04-24 23:29 UTC, Michael Knepher
no flags Details

Description Michael Knepher 2003-04-10 20:29:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586) Gecko/20030211 Galeon/1.3.3

Description of problem:
Every burn attempt, successful or otherwise results in a "power on,
reset, or bus device reset occurred" message during the fixate process.
Unsuccessful burns follow this up with an "incompatible medium" message.
The output from cdrecord for a successful burn followed by a failure is
attached. I started off getting a successful burn about every other time, now
just about every attempt fails.

I have no problems under 8.0 with this system (installed on a second hard drive). 

I've killed and removed magicdev, and turned DMA on/off. Nothing seems
to make a difference.

My system: K6-2 450, VIA MVP-4 chipset with integrated video/audio,
384MB RAM, Sony CRX120E ATAPI burner (4x8x2x). 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run cd burning front-end or cdrecord
2.
3.
    

Actual Results:  Every attempt has bus reset error, failures give "incompatible
medium" error.

Expected Results:  No errors, successfully burned disk.

Additional info:

GnomeToaster Recording Terminal
Recording 51937280 bytes to CD
GnomeToaster is calling the following command:
cdrecord dev=0,0,0 speed=4 -data tsize=51937280 /tmp/gtoaster
Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jrg Schilling
Using libscg version 'schily-0.7'
Device type    : Removable CD-ROM
Version        : 0
Response Format: 1
Vendor_info    : 'SONY    '
Identifikation : 'CD-RW  CRX120E  '
Revision       : '1.0j'
Device seems to be: Generic mmc CD-RW.
Using generic SCSI-3/mmc CD-R driver (mmc_cdr).
Driver flags   : MMC SWABAUDIO 
Supported modes: TAO PACKET SAO SAO/R96R RAW/R96R
Starting to write CD/DVD at speed 4 in real TAO mode for single session.
Last chance to quit, starting real write in 9 seconds.   8
seconds.   7 seconds.   6
seconds.   5 seconds.   4
seconds.   3 seconds.   2
seconds.   1 seconds.   0 seconds. Operation
starts.scsidev: '0,0,0'
scsibus: 0 target: 0 lun: 0
Linux sg driver version: 3.1.24
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.75-RH '@(#)scsi-linux-sg.c  1.75
02/10/21 Copyright 1997 J. Schilling').

fixating CDROM.

Track 01: Total bytes read/written: 51937280/51937280 (25360 sectors).
cdrecord: Input/output error. close track/session: scsi sendcmd: no
error
CDB:  5B 00 02 00 00 00 00 00 00 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 06 00 00 00 00 12 00 00 00 00 29 00 00 00
Sense Key: 0x6 Unit Attention, Segment 0
Sense Code: 0x29 Qual 0x00 (power on, reset, or bus device reset
occurred) Fru 0x0
Sense flags: Blk 0 (not valid) 
cmd finished after 64.976s timeout 480s
cmd finished after 64.976s timeout 480s
CD recording process finished.
Recording 51937280 bytes to CD
GnomeToaster is calling the following command:
cdrecord dev=0,0,0 speed=4 -data tsize=51937280 /tmp/gtoaster
Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jrg Schilling
Using libscg version 'schily-0.7'
Device type    : Removable CD-ROM
Version        : 0
Response Format: 1
Vendor_info    : 'SONY    '
Identifikation : 'CD-RW  CRX120E  '
Revision       : '1.0j'
Device seems to be: Generic mmc CD-RW.
Using generic SCSI-3/mmc CD-R driver (mmc_cdr).
Driver flags   : MMC SWABAUDIO 
Supported modes: TAO PACKET SAO SAO/R96R RAW/R96R
Starting to write CD/DVD at speed 4 in real TAO mode for single session.
Last chance to quit, starting real write in 9 seconds.   8
seconds.   7 seconds.   6
seconds.   5 seconds.   4
seconds.   3 seconds.   2
seconds.   1 seconds.   0 seconds. Operation
starts.scsidev: '0,0,0'
scsibus: 0 target: 0 lun: 0
Linux sg driver version: 3.1.24
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.75-RH '@(#)scsi-linux-sg.c  1.75
02/10/21 Copyright 1997 J. Schilling').

fixating CDROM.

Track 01: Total bytes read/written: 51937280/51937280 (25360 sectors).
cdrecord: Input/output error. close track/session: scsi sendcmd: no
error
CDB:  5B 00 02 00 00 00 00 00 00 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 06 00 00 00 00 12 00 00 00 00 29 00 00 00
Sense Key: 0x6 Unit Attention, Segment 0
Sense Code: 0x29 Qual 0x00 (power on, reset, or bus device reset
occurred) Fru 0x0
Sense flags: Blk 0 (not valid) 
cmd finished after 25.137s timeout 480s
cmd finished after 25.137s timeout 480s
cdrecord: Input/output error. test unit ready: scsi sendcmd: no error
CDB:  00 00 00 00 00 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 02 00 00 00 00 12 00 00 00 00 30 00 00 00
Sense Key: 0x2 Not Ready, Segment 0
Sense Code: 0x30 Qual 0x00 (incompatible medium installed) Fru 0x0
Sense flags: Blk 0 (not valid) 
cmd finished after 0.656s timeout 40s
CD recording process finished.

Comment 1 Harald Hoyer 2003-04-13 11:35:42 UTC
sounds more like a kernel problem to me... arjan?

Comment 2 Arjan van de Ven 2003-04-13 11:38:53 UTC
I'm not convinced of that harald; the kernel is merely the messenger of the bad
news of a command cdrecord sends not going down well with the device.

Comment 3 Harald Hoyer 2003-04-13 11:57:34 UTC
Sense Code: 0x29 Qual 0x00 (power on, reset, or bus device reset occured)
There is nothing cdrecord can do about this and I do not think cdrecord does a
bus reset whilest burning/fixating...
Buggy hardware?

Comment 4 Michael Knepher 2003-04-13 16:17:23 UTC
I'm willing to admit buggy hardware if it'll get me a faster burner, but why
would the problem not show up under 8.0?

Comment 5 Michael Knepher 2003-04-24 23:29:01 UTC
Created attachment 91286 [details]
Output for cdrecord generated using k3b front-end

I now get consistently successful burns using k3b - gtoaster and xcdroast both
result in more failures than success. Perhaps the way they call cdrecord?

Comment 6 Harald Hoyer 2004-02-05 16:20:30 UTC
hmmm... there are newer kernels out there now... do you still
experience these problems?

Comment 7 Michael Knepher 2004-02-06 17:07:13 UTC
Seems to be solved with recent kernels. Can't recall last time I had 
a problem. Upgraded to FC1, no problems there either. 


Note You need to log in before you can comment on or make changes to this bug.