Bug 885592 - [RHS-C] SHD service status details are not displayed in "Services" tab in Cluster
[RHS-C] SHD service status details are not displayed in "Services" tab in Clu...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
All All
medium Severity high
: ---
: RHGS 2.1.2
Assigned To: Bala.FA
Shruti Sampat
: ZStream
: 902506 902829 (view as bug list)
Depends On:
Blocks: 919332
  Show dependency treegraph
 
Reported: 2012-12-10 02:23 EST by Prasanth
Modified: 2015-05-13 12:32 EDT (History)
14 users (show)

See Also:
Fixed In Version: CB11
Doc Type: Bug Fix
Doc Text:
Previously, the self heal daemon service status details were not displayed in 'Services' sub tab of Clusters. Now, with this update, the self heal daemon service details are displayed.
Story Points: ---
Clone Of:
: 919332 (view as bug list)
Environment:
Last Closed: 2014-02-25 02:23:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SHD_missing (139.23 KB, image/jpeg)
2012-12-10 02:23 EST, Prasanth
no flags Details
vdsm logs (17.25 KB, text/x-log)
2013-06-18 06:14 EDT, Shruti Sampat
no flags Details
engine logs (3.07 MB, text/x-log)
2013-06-18 06:15 EDT, Shruti Sampat
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 16177 None None None Never
oVirt gerrit 21599 None None None Never

  None (edit)
Description Prasanth 2012-12-10 02:23:58 EST
Created attachment 660612 [details]
SHD_missing

Description of problem:

SHD service status details are not displayed in "Services" tab in Cluster 

Version-Release number of selected component (if applicable): rhsc-2.1-qa18.el6ev.noarch


How reproducible: Always


Steps to Reproduce:
1. Select a Cluster and click on the sub-tab "Services "
2. You will see only NFS related details and not SHD

  
Actual results: Currently ONLY NFS service related details are seen and SHD service details are missing. Even if you select SHD from the drop-down, and click on "Filter", it doesn't show anything.

Expected results: SHD service status should also be displayed along with NFS as currently we support SHD service as well as per http://wiki.ovirt.org/Features/GlusterVolumeAdvancedDetails



Additional info: Screenshot attached

SHD service is running in the server. See below:

-----
# ps aux |grep glustershd
root     29047  0.1  0.1 318848 17588 ?        Ssl  Dec09   0:03 /usr/sbin/glusterfs -s localhost --volfile-id gluster/glustershd -p /var/lib/glusterd/glustershd/run/glustershd.pid -l /var/log/glusterfs/glustershd.log -S /var/run/bc939796854a60f449342f975c33068c.socket --xlator-option *replicate*.node-uuid=9dd0c92e-e929-43a0-aaff-d6c201e5d77d
-----

Even otherwise, it should say the status as DOWN instead of not displaying anything.
Comment 2 Kanagaraj 2012-12-18 04:28:00 EST
While calling volumeStatus, a REPLICATE volume should be passed as an argument to get the SHD details. The same will be applicable for NFS as well(the volume should have nfs enabled).

So the engine has to decide which volume to be passed as an argument when calling volumeStatus. A volume which is both REPLICATE and NFS=true should be selected. if nothing found, call the volumeStatus twice, first time with REPLICATE volume, second time with NFS enable volume and the results should be combined and shown to the user.

The services could be empty if the cluster has no REPLICATE volumes and no NFS enabled volumes.
Comment 3 Dhandapani 2012-12-24 06:04:06 EST
Patch sent to upstream: http://gerrit.ovirt.org/#/c/10336/
Comment 4 Shireesh 2013-01-22 00:33:45 EST
*** Bug 902506 has been marked as a duplicate of this bug. ***
Comment 5 Shireesh 2013-01-22 08:57:00 EST
*** Bug 902829 has been marked as a duplicate of this bug. ***
Comment 6 Matt Mahoney 2013-01-25 13:00:32 EST
When this bug was opened, there replicate volumes in Up state. Once a volume was added and "Up", then cluster services table was populated as expected.
Comment 7 Prasanth 2013-01-28 03:56:49 EST
(In reply to comment #2)
> While calling volumeStatus, a REPLICATE volume should be passed as an
> argument to get the SHD details. The same will be applicable for NFS as
> well(the volume should have nfs enabled).
> 
> So the engine has to decide which volume to be passed as an argument when
> calling volumeStatus. A volume which is both REPLICATE and NFS=true should
> be selected. if nothing found, call the volumeStatus twice, first time with
> REPLICATE volume, second time with NFS enable volume and the results should
> be combined and shown to the user.
> 
> The services could be empty if the cluster has no REPLICATE volumes and no
> NFS enabled volumes.

Kanagaraj, instead of showing the services as empty when a cluster has no REPLICATE volumes and no NFS enabled volumes, it will be good if we can provide a useful message or s pop-up window in the "Services" tab providing the reason.
Comment 8 Matt Mahoney 2013-02-26 15:05:44 EST
Created a Replicate volume, started the volume, and both NFS and SHD details were present.
Comment 9 Matt Mahoney 2013-02-26 15:06:25 EST
Tested against QA6.
Comment 11 Shruti Sampat 2013-06-18 06:01:36 EDT
I am seeing this issue in bb3. Moving the bug to ASSIGNED.
Comment 12 Shruti Sampat 2013-06-18 06:08:36 EDT
Another issue that I see, is that when none of the hosts and none of the services are selected from the respective drop-down menus, the Console does not display any services, whereas all services on all hosts should be displayed.
Comment 13 Shruti Sampat 2013-06-18 06:11:23 EDT
Attaching engine logs and vdsm logs.
Comment 14 Shruti Sampat 2013-06-18 06:14:07 EDT
Created attachment 762456 [details]
vdsm logs
Comment 15 Shruti Sampat 2013-06-18 06:15:14 EDT
Created attachment 762457 [details]
engine logs
Comment 16 Sahina Bose 2013-06-18 06:55:23 EDT
In the logs, see this:
2013-06-18 15:24:44,102 ERROR [org.ovirt.engine.core.bll.gluster.GetGlusterVolumeAdvancedDetailsQuery] (ajp-/127.0.0.1:8702-2) To get service details, no Nfs or Replicated volumes found in the cluster.

Can you give output of gluster volume status?
Comment 17 Kanagaraj 2013-06-18 06:59:43 EDT
Sahina,

This is the log when the user selects a cluster which doesn't have any volumes.
Comment 18 Sahina Bose 2013-06-25 03:15:59 EDT
Shruti,

The vdsm logs is from host 10.70.35.107? 
Is this host part of your "myglustercluster" ?
Comment 19 Shruti Sampat 2013-06-25 03:28:21 EDT
Sahina,

The screenshot is an older attachment that was uploaded earlier from another setup. The logs that I have attached are not from the same setup. So the machine 10.70.35.107 is not part of 'myglustercluster' seen in the screenshot.
Comment 21 Shruti Sampat 2013-07-08 07:47:08 EDT
Verfified as fixed in Red Hat Storage Console Version: 2.1.0-0.bb5.el6rhs. The NFS and SHD services details are being displayed for all possible combinations of hosts and service type.
Comment 22 Shruti Sampat 2013-07-08 08:35:36 EDT
Seeing another issue. Filtering on a specified host and service has issues, the result appears and then disappears, and this keeps happening. 'ShowAll' works fine. 

Moving to ASSIGNED state.
Comment 24 Bala.FA 2013-11-25 04:31:41 EST
upstream vdsm patch is at http://gerrit.ovirt.org/#/c/21596/
downstream glusterfs patch is at https://code.engineering.redhat.com/gerrit/#/c/15759/
Comment 25 Bala.FA 2013-11-29 05:02:39 EST
Downstream vdsm patch https://code.engineering.redhat.com/gerrit/#/c/16544/
Comment 26 Dustin Tsang 2013-12-16 11:24:39 EST
The validation message isn't quite accurate which may confuse the user since validation is shown when the number of bricks less than equal to 4. As prasanth pointed out before, 0 and 4 are both a multiples of 4.

multiple is also misspelled in the current validation message.


current validation message: "Number of bricks should be a mutiple of Stripe Count"

suggested; something similar to: "Number of bricks should be a multiple of Stripe Count with a minimum of 8 bricks"
Comment 27 Sahina Bose 2013-12-17 00:02:41 EST
The comment 26 is not relevant to the SHD service details. I'm moving this back to ON_QA. Please provide correct details, if you're failing again.
Comment 28 Shruti Sampat 2013-12-19 00:30:43 EST
Verified as fixed in Red Hat Storage Console Version: 2.1.2-0.27.beta.el6_5.
Comment 29 Shalaka 2014-01-09 03:53:31 EST
Please review and signoff the edited DocText.
Comment 30 Bala.FA 2014-01-09 04:01:54 EST
doc-text looks good to me.
Comment 32 errata-xmlrpc 2014-02-25 02:23:19 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.