Bug 88566 (rcn:key) - neat improperly imports KEY line from existing ifcfg file for wireless nic
Summary: neat improperly imports KEY line from existing ifcfg file for wireless nic
Status: CLOSED RAWHIDE
Alias: rcn:key
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network   
(Show other bugs)
Version: 9
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
: 88810 97719 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-10 22:41 UTC by Dax Kelson
Modified: 2007-04-18 16:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-22 08:39:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dax Kelson 2003-04-10 22:41:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I had an existing, working, ifcfg-eth1 file for my wireless NIC. After running
redhat-config-network to setup a PPP connection, it changed the wep KEY line,
causing my wireless 802.11b connection to fail the next time I tried using it.

I had the following /etc/sysconfig/network-scripts/ifcfg-eth1 file:

(note that I replaced my real WEP key and ESSID with a fake one)

# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
USERCTL=yes
PEERDNS=yes
GATEWAY=
TYPE=Wireless
DEVICE=eth1
HWADDR=00:03:21:5a:4e:52
BOOTPROTO=dhcp
NETMASK=
ONBOOT=no
DHCP_HOSTNAME=
IPADDR=
NAME=
DOMAIN=
#CHANNEL=1
ESSID=FOO
MODE=Managed
KEY='d4013a539ce2a3ca8e2061d3e4d054b8 restricted'
#RATE=2Mb/s
RATE=
CHANNEL=

After I ran redhat-config-network, it changed to:

(note the change in the KEY line)

# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
USERCTL=yes
PEERDNS=yes
GATEWAY=
TYPE=Wireless
DEVICE=eth1
HWADDR=00:03:21:5a:4e:52
BOOTPROTO=dhcp
NETMASK=
ONBOOT=no
DHCP_HOSTNAME=
IPADDR=
NAME=
DOMAIN=
#CHANNEL=1
ESSID=FOO
MODE=Managed
KEY='s:d4013a539ce2a3ca8e2061d3e4d054b8 restricted'
#RATE=2Mb/s
RATE=
CHANNEL=

Version-Release number of selected component (if applicable):
redhat-config-network-1.2.0-2

How reproducible:
Didn't try

Steps to Reproduce:
1. Have existing ifcfg-ethX file with KEY entry for WEP
2. Run redhat-config-network to do something not related to the interface
3. Observe the KEY line get mangled
    

Additional info:

Comment 1 Harald Hoyer 2003-04-14 13:39:12 UTC
should be fixed with the update from:
http://people.redhat.com/harald/redhat-config-network

Comment 2 Harald Hoyer 2003-04-14 15:33:02 UTC
*** Bug 88810 has been marked as a duplicate of this bug. ***

Comment 3 Murray Cumming 2003-04-21 07:21:36 UTC
That solved a similar problem for me, when changing from WEP to no-WEP:

# ifup eth0
Error for wireless request "Set Encode" (8B2A) :
    invalid argument "s:".

(This is with a Cisco Aeronet 350 PCMCIA card)

I hope this gets into RHN and/or 9.1.

Comment 4 Harald Hoyer 2003-06-27 10:26:59 UTC
*** Bug 97719 has been marked as a duplicate of this bug. ***

Comment 5 Harald Hoyer 2003-08-07 13:52:39 UTC
prefix hexadecimal keys with a "0x"


Note You need to log in before you can comment on or make changes to this bug.