Bug 885887 - service fails to start with leading white space in config
service fails to start with leading white space in config
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openstack-quantum (Show other bugs)
17
All Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Gary Kotton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-10 17:11 EST by Jon Thomas
Modified: 2016-04-26 09:31 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-11 08:35:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1088814 None None None Never

  None (edit)
Description Jon Thomas 2012-12-10 17:11:00 EST
Leading whitespace in l3_agent.ini param causes a parse error and the service won't start

" usenamespace = False" fail 
vs 
"usenamespace = False" works

Looks like a common parser

quantum-l3-agent.service - OpenStack Quantum Layer 3 Agent
	  Loaded: loaded (/usr/lib/systemd/system/quantum-l3-agent.service; disabled)
	  Active: failed (Result: exit-code) since Mon, 10 Dec 2012 17:09:56 -0500; 7s ago
	 Process: 16746 ExecStart=/usr/bin/quantum-l3-agent --config-file /etc/quantum/quantum.conf --config-file /etc/quantum/l3_agent.ini --log-file /var/log/quantum/l3-agent.log (code=exited, status=1/FAILURE)
	  CGroup: name=systemd:/system/quantum-l3-agent.service

Dec 10 17:09:56 basin.redhat.com quantum-l3-agent[16746]: Traceback (most recent call last):
Dec 10 17:09:56 basin.redhat.com quantum-l3-agent[16746]: File "/usr/bin/quantum-l3-agent", line 20, in <module>
Dec 10 17:09:56 basin.redhat.com quantum-l3-agent[16746]: main()
Dec 10 17:09:56 basin.redhat.com quantum-l3-agent[16746]: File "/usr/lib/python2.7/site-packages/quantum/agent/l3_agent.py", line 527, in main
Dec 10 17:09:56 basin.redhat.com quantum-l3-agent[16746]: conf(sys.argv)
Dec 10 17:09:56 basin.redhat.com quantum-l3-agent[16746]: File "/usr/lib/python2.7/site-packages/quantum/openstack/common/cfg.py", line 1026, in __call__
Dec 10 17:09:56 basin.redhat.com quantum-l3-agent[16746]: self._parse_config_files()
Dec 10 17:09:56 basin.redhat.com quantum-l3-agent[16746]: File "/usr/lib/python2.7/site-packages/quantum/openstack/common/cfg.py", line 1492, in _parse_config_files
Dec 10 17:09:56 basin.redhat.com quantum-l3-agent[16746]: raise ConfigFileParseError(pe.filename, str(pe))
Dec 10 17:09:56 basin.redhat.com quantum-l3-agent[16746]: quantum.openstack.common.cfg.ConfigFileParseError: Failed to parse /etc/quantum/l3_agent.ini: at /etc/quantum/l3_agent.ini:29, Unexpected continuation line: ' use_namespaces = False'
Comment 1 Gary Kotton 2012-12-11 03:48:35 EST
Hi,
This is problematic accross all of the openstack projects. I have opened a bug upstream and have posted a patch:
https://bugs.launchpad.net/oslo/+bug/1088814
Thanks
Gary
Comment 2 Gary Kotton 2012-12-11 08:35:21 EST
Hi,
This is considered a user error. Please note that whitespaces are currently not supported as it is considered "non standard". Please look at the rejected bug upstream - this has the relevant explanations.
Thanks
Gary
Comment 3 Jon Thomas 2012-12-11 09:01:39 EST
Thanks. Created a kb article.

Note You need to log in before you can comment on or make changes to this bug.