Bug 885888 - Swift initscript has empty "reload"
Swift initscript has empty "reload"
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-swift (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: snapshot2
: 2.1
Assigned To: Alan Pevec
Attila Fazekas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-10 17:15 EST by Pete Zaitcev
Modified: 2013-02-14 13:23 EST (History)
1 user (show)

See Also:
Fixed In Version: openstack-swift-1.7.4-7.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-14 13:23:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Removed reload from init scripts (6.94 KB, patch)
2013-01-15 10:04 EST, Flavio Percoco
no flags Details | Diff

  None (edit)
Description Pete Zaitcev 2012-12-10 17:15:14 EST
Description of problem:

"service openstack-swift-proxy reload" does nothing

Version-Release number of selected component (if applicable):

1.7.4-2

Additional info:

    restart)
        $1
        ;;
    reload)
        ;;

It should invoke swift-init all reload or something. Failing that,
just remove the clause and let the script error out.
Comment 2 Flavio Percoco 2013-01-15 10:04:19 EST
Created attachment 678826 [details]
Removed reload from init scripts

I removed reload from every init script in order to keep consistency between them. It could be added again for scripts that we do have something to execute in that clause.
Comment 4 Attila Fazekas 2013-02-01 10:02:44 EST
swift-init -h
....
reload: graceful shutdown then restart on supporting servers
....
 -g, --graceful        send SIGHUP to supporting servers


Our initscript using the SIGTERM which means stopping services without letting the workers to finish serving the in-progress requests.

So the reload should use -1 SIGHUP instead of SIGTERM and it is a big difference.
Comment 5 Pete Zaitcev 2013-02-01 12:41:54 EST
This is exactly why Flavio's approach is correct: don't fool people into
thinking that our scripted reload does it correctly. They can use swift-init
to do it.
Comment 12 errata-xmlrpc 2013-02-14 13:23:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0260.html

Note You need to log in before you can comment on or make changes to this bug.