Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 885982 - Guest with no -spice option abort after boot about 2 min
Summary: Guest with no -spice option abort after boot about 2 min
Keywords:
Status: CLOSED DUPLICATE of bug 873563
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Virtualization Maintenance
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-11 08:57 UTC by langfang
Modified: 2012-12-11 09:50 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-11 09:50:20 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description langfang 2012-12-11 08:57:58 UTC
Description of problem:

Boot guest with no spice option,wait about 2 min, guest abort.

Version-Release number of selected component (if applicable):
Host:
# uname -r
2.6.32-347.el6.x86_64
# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.340.el6.x86_64
Guest:
2.6.32-347.el6.x86_64

How reproducible:

Always

Steps to Reproduce:
1.Boot guest with  no spice option
...-vga qxl...
2.Wait about 2 min


  
Actual results: Guest abort

(qemu) [New Thread 0x7fff577ee700 (LWP 15868)]
[Thread 0x7fff577ee700 (LWP 15868) exited]
[New Thread 0x7fff577ee700 (LWP 15873)]
(/usr/bin/gdb:15852): SpiceWorker-ERROR **: red_worker.c:10732:handle_dev_update: assertion `worker->running' failed
Detaching after fork from child process 15874.

Program received signal SIGABRT, Aborted.
[Switching to Thread 0x7fffecb0a700 (LWP 15866)]
0x00007ffff57468a5 in raise () from /lib64/libc.so.6
(gdb) bt
#0  0x00007ffff57468a5 in raise () from /lib64/libc.so.6
#1  0x00007ffff5748085 in abort () from /lib64/libc.so.6
#2  0x00007ffff5fa10d5 in spice_logv (log_domain=0x7ffff601d314 "SpiceWorker", log_level=SPICE_LOG_LEVEL_ERROR,
    strloc=0x7ffff601efa9 "red_worker.c:10732", function=0x7ffff60209c0 "handle_dev_update",
    format=0x7ffff60180d8 "assertion `%s' failed", args=0x7fffecb09980) at log.c:109
#3  0x00007ffff5fa120a in spice_log (log_domain=<value optimized out>, log_level=<value optimized out>, strloc=<value optimized out>,
    function=<value optimized out>, format=<value optimized out>) at log.c:123
#4  0x00007ffff5f80dae in handle_dev_update (opaque=0x7fffe40008c0, payload=<value optimized out>) at red_worker.c:10732
#5  0x00007ffff5f5eca7 in dispatcher_handle_single_read (dispatcher=0x7ffff87549e8) at dispatcher.c:139
#6  dispatcher_handle_recv_read (dispatcher=0x7ffff87549e8) at dispatcher.c:162
#7  0x00007ffff5f7f9de in red_worker_main (arg=<value optimized out>) at red_worker.c:11835
#8  0x00007ffff773d851 in start_thread () from /lib64/libpthread.so.0
#9  0x00007ffff57fc90d in clone () from /lib64/libc.so.6
(gdb) 


Host:#nc -U /tmp/tty0
...
Starting NetworkManager daemon: [  OK  ]
Starting Avahi daemon... [  OK  ]
Starting NFS statd: [  OK  ]
Starting RPC idmapd: [  OK  ]
Starting cups: [  OK  ]
Mounting other filesystems:  [  OK  ]
Starting acpi daemon: [  OK  ]
Starting HAL daemon: [  OK  ]
Retrigger failed udev events[  OK  ]
Loading autofs4: [  OK  ]
Starting automount: [  OK  ]
Starting mcelog daemon
Starting sshd: [  OK  ]
Starting postfix: [  OK  ]
Starting abrt daemon: [  OK  ]
Starting crond: [  OK  ]
Starting atd: [  OK  ]
Starting rhsmcertd 240 1440[  OK  ]
Starting certmonger: [  OK  ]

Red Hat Enterprise Linux Server release 6.3 (Santiago)
Kernel 2.6.32-347.el6.x86_64 on an x86_64

intel-5130-16-1.englab.nay.redhat.com login: 



Expected results:
Guest work normally.

Additional info:

CLI:/usr/libexec/qemu-kvm -M rhel6.4.0 -m 2G  -enable-kvm -cpu Opteron_G2 -smp 2,sockets=2,cores=1,threads=1 -name rhel6.4-64 -rtc base=localtime,clock=host,driftfix=slew  -uuid `uuidgen` -monitor stdio  -drive file=/home/rhel6.4-64-copy1.raw,if=none,id=drive-virtio-disk0,format=raw,cache=none,aio=native,media=disk,werror=stop,rerror=stop -device virtio-scsi-pci,id=bus1 -device scsi-hd,bus=bus1.0,drive=drive-virtio-disk0,id=virtio-scsi-pci0 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device e1000,netdev=hostnet0,id=net0,mac=14:67:E6:97:58:89 -device virtio-balloon-pci,id=balloon0,bus=pci.0 -chardev socket,id=serial_isa_1,path=/tmp/tty0,server,nowait -device isa-serial,chardev=serial_isa_1 -usb -device usb-tablet -qmp tcp:0:4444,server,nowait  -vga qxl 

HOst:
model name	: Dual-Core AMD Opteron(tm) Processor 1216

Comment 2 juzhang 2012-12-11 09:50:20 UTC

*** This bug has been marked as a duplicate of bug 873563 ***


Note You need to log in before you can comment on or make changes to this bug.