Bug 886068 - libguestfs cannot inspect guests which use EFI booting
libguestfs cannot inspect guests which use EFI booting
Status: CLOSED NOTABUG
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-11 07:51 EST by Richard W.M. Jones
Modified: 2012-12-11 10:04 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-11 10:04:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2012-12-11 07:51:12 EST
Description of problem:

libguestfs cannot inspect guests which use EFI to boot.  (I
don't think such "guests" really exist, but this is a problem
for P2V where a physical machine becomes a guest).

Version-Release number of selected component (if applicable):

libguestfs 1.19.66

How reproducible:

Reproducible.

Steps to Reproduce:
1. virt-inspector -a /path/to/a/p2v.img

Additional info:

sda1 partition contains:

/boot/efi/
/boot/efi/EFI
/boot/efi/EFI/fedora
/boot/efi/EFI/fedora/fonts
/boot/efi/EFI/fedora/fonts/unicode.pf2
/boot/efi/EFI/fedora/grub.cfg
/boot/efi/EFI/fedora/gcdx64.efi
/boot/efi/EFI/fedora/grubx64.efi
/boot/efi/EFI/fedora/shim.efi

sda2 partition contains:

/boot/
/boot/lost+found
/boot/config-3.6.9-4.fc18.x86_64
/boot/System.map-3.6.9-4.fc18.x86_64
/boot/efi
/boot/.vmlinuz-3.6.9-4.fc18.x86_64.hmac
/boot/vmlinuz-3.6.9-4.fc18.x86_64
/boot/initramfs-3.6.9-4.fc18.x86_64.img
/boot/grub2
/boot/grub2/themes
/boot/grub2/themes/system
/boot/grub2/themes/system/boot_menu_e.png
/boot/grub2/themes/system/fireworks.png
/boot/grub2/themes/system/terminal_box_ne.png
/boot/grub2/themes/system/blob_w.png
/boot/grub2/themes/system/boot_menu_w.png
/boot/grub2/themes/system/slider_c.png
/boot/grub2/themes/system/terminal_box_sw.png
/boot/grub2/themes/system/README
/boot/grub2/themes/system/COPYING.CC-BY-SA-3.0
/boot/grub2/themes/system/boot_menu_s.png
/boot/grub2/themes/system/slider_n.png
/boot/grub2/themes/system/DejaVuSans-Bold-14.pf2
/boot/grub2/themes/system/DejaVuSans-10.pf2
/boot/grub2/themes/system/DejaVuSans-12.pf2
/boot/grub2/themes/system/boot_menu_ne.png
/boot/grub2/themes/system/terminal_box_se.png
/boot/grub2/themes/system/terminal_box_n.png
/boot/grub2/themes/system/terminal_box_e.png
/boot/grub2/themes/system/theme.txt
/boot/grub2/themes/system/boot_menu_se.png
/boot/grub2/themes/system/boot_menu_c.png
/boot/grub2/themes/system/boot_menu_sw.png
/boot/grub2/themes/system/terminal_box_nw.png
/boot/grub2/themes/system/terminal_box_s.png
/boot/grub2/themes/system/terminal_box_w.png
/boot/grub2/themes/system/background.png
/boot/grub2/themes/system/slider_s.png
/boot/grub2/themes/system/boot_menu_nw.png
/boot/grub2/themes/system/unicode.pf2
/boot/grub2/themes/system/boot_menu_n.png
/boot/grub2/themes/system/terminal_box_c.png
/boot/grub2/grubenv
/boot/initrd-plymouth.img
Comment 1 Richard W.M. Jones 2012-12-11 08:13:21 EST
Turns out this is a problem for v2v too, because ESX 5.1
(the latest) will present EFI to guests.
Comment 2 Richard W.M. Jones 2012-12-11 10:04:41 EST
Apparently this was a bug in virt-v2v, not libguestfs,
so closing.

Note You need to log in before you can comment on or make changes to this bug.