Bug 88633 - rhn-applet-gui using all CPU resources
rhn-applet-gui using all CPU resources
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rhn-applet (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-11 12:44 EDT by Todd Wilson
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-30 10:43:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Todd Wilson 2003-04-11 12:45:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; Win 9x 4.90; Q312461)

Description of problem:
if I logon through gnome as a non-root user and run top I see that rhn-applet-
gui is taking over 95% of my CPU...
(NOTE: this non-root user is a member of every group on my system )

if I logon through gnome as root and run top I don't have this issue


Version-Release number of selected component (if applicable):
rhn-applet-2.0.9-0.8.0.1

How reproducible:
Always

Steps to Reproduce:
1.boot system
2.logon as a non-root user through the GNOME console
3.look at CPU usage
    

Actual Results:  CPU is running at over 95% utilization

Expected Results:  CPU should be running at under 5%

Additional info:
Comment 1 Daniel Veillard 2003-04-11 15:02:53 EDT
Of course I can't reproduce this, you need to provide more informations.
Try to launch rhn-applet-gui from a shell and see is there is any error message.
If you know how to use gdb launch it on python and run with the
/usr/bin/rhn-applet-gui argument, then abort it to get a stack trace.

Daniel
Comment 2 Todd Wilson 2003-04-11 16:01:06 EDT
if I run rhn-applet-gui from the shell it runs fine ( no errors and CPU usuage 
is at ~3% )and I can see the icon come up on my GNOME pannel...

Comment 3 Daniel Veillard 2003-04-11 18:12:39 EDT
Then I have really no idea, that means the applet itself is fine
it's the way it is started which gives troubles. Why and how, there
is nothing allowing me to reproduce or debug the problem, I can't
reproduce this, and apparently you're the only one having the
problem. Try to see if there are error messages logged
in your X session logs, maybe there is something wrong in the setup 
not allowing the applet to connect to the Xsession or to the panel...

Daniel
Comment 4 Daniel Veillard 2004-11-30 10:43:51 EST
This is more than one year old and I didn't got any error report
about this since, I think this can safely be closed.

Daniel 

Note You need to log in before you can comment on or make changes to this bug.