Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 886459 - service firewalld restart works but it writes 'connection != NULL' failed' into logs
Summary: service firewalld restart works but it writes 'connection != NULL' failed' i...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: firewalld
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-12 10:45 UTC by Petr Sklenar
Modified: 2013-01-03 19:13 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-03 19:13:31 UTC
Type: Bug


Attachments (Terms of Use)

Description Petr Sklenar 2012-12-12 10:45:41 UTC
Description of problem:
service firewalld restart  works but it writes into /var/log/message:
connection != NULL

Version-Release number of selected component (if applicable):
NetworkManager-0.9.7.0-9.git20121004.fc18.x86_64
firewalld-0.2.11-1.fc18.noarch

How reproducible:
deterministic

Steps to Reproduce:
1, [root@qa-psklenar ~]# service firewalld restart
Redirecting to /bin/systemctl restart  firewalld.service
2, [root@qa-psklenar ~]# echo $?
0
[root@qa-psklenar ~]# tail /var/log/message


Actual results:
Dec 12 05:43:01 qa-psklenar systemd[1]: Stopping firewalld - dynamic firewall daemon...
Dec 12 05:43:02 qa-psklenar kernel: [ 7158.249015] Ebtables v2.0 unregistered
Dec 12 05:43:02 qa-psklenar systemd[1]: Starting firewalld - dynamic firewall daemon...
Dec 12 05:43:02 qa-psklenar NetworkManager[759]: nm_connection_get_setting_connection: assertion `connection != NULL' failed
Dec 12 05:43:02 qa-psklenar systemd[1]: Started firewalld - dynamic firewall daemon.
Dec 12 05:43:02 qa-psklenar kernel: [ 7158.570599] ip6_tables: (C) 2000-2006 Netfilter Core Team
Dec 12 05:43:02 qa-psklenar kernel: [ 7158.584896] Ebtables v2.0 registered
Dec 12 05:43:02 qa-psklenar kernel: [ 7158.638512] nf_conntrack version 0.5.0 (16384 buckets, 65536 max)


Expected results:
no such a fail about '`connection != NULL'

Additional info:

Comment 1 Petr Sklenar 2012-12-12 13:02:02 UTC
then running like a user could say nicer error:
[psklenar@qa-psklenar ~]$ firewall-cmd --reload
Error: org.fedoraproject.slip.dbus.service.PolKit.NotAuthorizedException.org.fedoraproject.FirewallD1.config: 
[psklenar@qa-psklenar ~]$ echo $?
254

Comment 2 Jiri Popelka 2012-12-12 13:48:03 UTC
(In reply to comment #0)
> Dec 12 05:43:02 qa-psklenar NetworkManager[759]:
> nm_connection_get_setting_connection: assertion `connection != NULL' failed

That comes from libnm.
NetworkManager calls that function on *many* places so it's hard to say what's the culprit moreover when I don't see it myself. Greping /var/log/messages history hasn't shown anything like that here.

Comment 3 Jiri Popelka 2012-12-12 14:58:42 UTC
(In reply to comment #1)
> [psklenar@qa-psklenar ~]$ firewall-cmd --reload
> Error:
> org.fedoraproject.slip.dbus.service.PolKit.NotAuthorizedException.org.
> fedoraproject.FirewallD1.config: 

This should show a polkit authentication dialog ? not sure what's wrong

Comment 5 Petr Sklenar 2012-12-12 15:03:33 UTC
(In reply to comment #3)
> (In reply to comment #1)
> > [psklenar@qa-psklenar ~]$ firewall-cmd --reload
> > Error:
> > org.fedoraproject.slip.dbus.service.PolKit.NotAuthorizedException.org.
> > fedoraproject.FirewallD1.config: 
> 
> This should show a polkit authentication dialog ? not sure what's wrong

running like the user, its terminal output;
the similar as bug 886529

Comment 6 Petr Sklenar 2012-12-12 15:06:53 UTC
(In reply to comment #5)
> (In reply to comment #3)
> > (In reply to comment #1)
> > > [psklenar@qa-psklenar ~]$ firewall-cmd --reload
> > > Error:
> > > org.fedoraproject.slip.dbus.service.PolKit.NotAuthorizedException.org.
> > > fedoraproject.FirewallD1.config: 
> > 
> > This should show a polkit authentication dialog ? not sure what's wrong
> 
> running like the user, its terminal output;
> the similar as bug 886529

I can see this issue  when running without X environment only, lets move our discussion to bug 886529

Comment 7 Thomas Woerner 2013-01-03 19:13:31 UTC
Closing as NOT A BUG, see #886529.


Note You need to log in before you can comment on or make changes to this bug.