Bug 886644 - python-ethtool 0.6.2 - ipv4_address shows None
python-ethtool 0.6.2 - ipv4_address shows None
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-ethtool (Show other bugs)
6.4
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Dave Malcolm
Branislav Náter
: Regression
Depends On:
Blocks: 879148 888457
  Show dependency treegraph
 
Reported: 2012-12-12 13:34 EST by Douglas Schilling Landgraf
Modified: 2013-02-21 05:48 EST (History)
2 users (show)

See Also:
Fixed In Version: python-ethtool-0.6-3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:48:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Douglas Schilling Landgraf 2012-12-12 13:34:04 EST
Description of problem:

Cannot collect ipv4 address:
python-ethtool 0.6.2 

== Demo ==
import ethtool

devs = ethtool.get_interfaces_info(ethtool.get_devices())

for d in devs:
        print "*** Device: %s:" % d.device
        print "MAC Addr: %s" % d.mac_address
        print "IPv4: %s/%s Brd: %s" % (d.ipv4_address, d.ipv4_netmask, d.ipv4_broadcast)

# python pethtool.py 
*** Device: breth0:
MAC Addr: 52:54:00:9C:72:7C
IPv4: None/0 Brd: None   <---------------- None 

# rpm -Uvh --oldpackage python-ethtool-0.6-1.el6.x86_64.rpm

Now the IPv4 appears:
# python pethtool.py 
*** Device: breth0:
MAC Addr: 52:54:00:9C:72:7C
IPv4: 192.168.122.156/24 Brd: 192.168.122.255

This bug is affect RHEV-H 6.4.
Comment 2 RHEL Product and Program Management 2012-12-12 21:29:52 EST
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 13 errata-xmlrpc 2013-02-21 05:48:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0454.html

Note You need to log in before you can comment on or make changes to this bug.