Bug 886744 - [de_DE] Test case failure: L10N: Manage Organizations
[de_DE] Test case failure: L10N: Manage Organizations
Status: CLOSED DUPLICATE of bug 886718
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
Unspecified Linux
medium Severity medium (vote)
: Unspecified
: 6.0
Assigned To: Miroslav Suchý
SAM QE List
: i18n, Translation, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-12 21:56 EST by Hedda Peters
Modified: 2014-09-18 12:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 03:45:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hedda Peters 2012-12-12 21:56:29 EST
Filed from caserun https://tcms.engineering.redhat.com/run/53065/#caserun_1907281 

Version-Release number of selected component (if applicable):
SAM-20121130.n.0

Steps to Reproduce: 

2. Add New Environment

  * Click on the name of the required organization from the left panel.
  * Click the Add New Environment button on the Details tab.
  * Type in a name in the Name field.
  * Don't assign a description/label (I think)
  * Select the Prior Environment from the drop-down menu.
  * Click the Create button to save your changes.


Actual results: 
Error message 

"A label was not provided during %s creation; therefore, a label of '%s' was automatically assigned. If you would like a different label, please delete the %s and recreate it with the desired label." 

cannot be translated correctly for de-DE (and some other languages), because "the" and "it" requires different translation depending on the noun that follows. 
The first %s variable is also troublesome for de-DE. The translation for %s and "creation" needs to be contracted into one single word, depending on %s with an added letter in between or not.


Expected results:
Correct translation for every use case of this error message. Variables may need to be avoided here.
Comment 1 Tom McKay 2012-12-18 09:24:17 EST
Mass move of i18n to CFSE where they are present as well
Comment 3 Miroslav Suchý 2013-02-12 05:03:07 EST
Current translations is:
msgid ""
"A label was not provided during %s creation; therefore, a label of '%s' was "
"automatically assigned. If you would like a different label, please delete "
"the %s and recreate it with the desired label."
msgstr ""
"Während der %s-Erstellung wurde kein Label angegeben, aus diesem Grund wurde "
"automatisch das Label '%s' zugewiesen. Falls Sie ein anderes Label verwenden "
"möchten, löschen Sie bitte d. %s und erstellen Sie es mit dem gewünschten "
"Label."

Please either suggest better translation, or even better source sentence, which can be then translated better. But please keep the semantic and the variables.
Comment 4 Hedda Peters 2013-02-12 18:19:01 EST
With the existing source string I am unable to provide a better translation, as outlined in #0

A better source string would be avoiding the first and third variable, e.g.:

"A label was not provided during environment creation; therefore, a label of '%s' was "
"automatically assigned. If you would like a different label, please delete "
"the environment and recreate it with the desired label."

I need to know what the first and third variable stand for in order to provide a good translation. My current translation is trying to make the best of it, but will still be grammatically wrong in some cases, depending on what the variables are replaced with.
Comment 5 Miroslav Suchý 2013-02-13 03:43:24 EST
The code is:
    label_assigned_text = _("A label was not provided during %s creation; therefore, a label of '%s' was " +
                            "automatically assigned. If you would like a different label, please delete the " +
                            "%s and recreate it with the desired label.") % [object_type, label, object_type]

so first and third parametr is the same.
Object_type can be e.g. repository, environment, organization, product etc.
I would say that having both object_type and label in message is MUST item. And if necessary I would prefer less gramatical correct translations, but with both values as it gives admin necessary information.
Comment 6 Miroslav Suchý 2013-02-13 03:45:56 EST
I just find that the same string is discussed in ru_RU bugzilla. Merging with that bugzilla to discuss it on one place.

*** This bug has been marked as a duplicate of bug 886718 ***

Note You need to log in before you can comment on or make changes to this bug.