Bug 886790 - [ALL_LANG][SAM CLI] Unlocalized strings for version module
[ALL_LANG][SAM CLI] Unlocalized strings for version module
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
x86_64 Linux
medium Severity medium (vote)
: Unspecified
: 6.0
Assigned To: Miroslav Suchý
SAM QE List
: i18n, Translation, Triaged
: 886752 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-13 02:47 EST by Noriko Mizumoto
Modified: 2014-09-18 12:47 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-12 04:41:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noriko Mizumoto 2012-12-13 02:47:14 EST
Filed from caserun (INSERT URL HERE)

Version-Release number of selected component (if applicable):
SAM-20121130.n.0

Steps to Reproduce: 

# headpin version -h

# headpin version

# headpin -u admin -p admin -v

# headpin -u admin -p admin version

# headpin -u admin -p admin version -g

# headpin -u admin -p admin version -v

# headpin -u admin -p admin version --noheading

# headpin -u admin -p admin version -g -v -d DELIMITER --noheading

 

 



Actual results: 
[root@i18nsamtest ~]# headpin version -h
Usage:  headpin <options> version <options>

Options:
  -h, --help    show this help message and exit
  -g            grep が使いやすい出力
  -v            詳細な構造化された出力
  -d DELIMITER  grep で認識できる出力内のコラム区切り記号、 -g オプションを付けた場合にのみ動作します
  --noheading   ヘッディングの出力を表示しません。出力を grep する場合に便利です。

Expected results:
All strings localized.
Comment 1 Yulia 2012-12-13 17:14:24 EST
Confirmed for Russian as well
Comment 2 Eunju, Kim 2012-12-13 18:42:23 EST
confirmed for ko-KR.
Comment 3 Hedda Peters 2012-12-13 20:23:03 EST
Confirmed for de-DE
Comment 4 Sam Friedmann 2012-12-13 20:24:54 EST
Confirmed for fr-FR.
Comment 5 Wei Liu 2012-12-13 20:40:01 EST
Confirmed for zh-CN.
Comment 6 Tom McKay 2012-12-18 09:12:14 EST
Mass moving i18n BZs to CFSE where they are also present
Comment 8 Ivan Necas 2013-01-22 11:01:04 EST
It seems we can't get Optparse that is in Python (at least 2.6) to make using our ugettext, therefore, messages generated by optparse can't be translated. This seems like an issue in Optparse, but this library is obsolete in later Python, therefore it doesn't seem possible to have it fixed all messages that come from optparse:

    no such option: %s
    ambiguous option: %s (%s?)
    Usage
    integer
    long integer
    floating-point
    complex
    option %s: invalid %s value: %r
    option %s: invalid choice: %r (choose from %s)
    show this help message and exit
    show program's version number and exit
    %prog [options]
    %s option requires an argument
    %s option requires %d arguments
    %s option does not take a value
    %s option requires an argument
    %s option requires %d arguments
    Options

I suggest marking this translations as WONTFIX
Comment 9 Miroslav Suchý 2013-02-12 04:41:20 EST
I agree with #8.

the line with --help will remain untranslated. Sorry.
Comment 10 Miroslav Suchý 2013-02-12 04:58:12 EST
*** Bug 886752 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.