Bug 887078 - [ALL_LANG][SAM CLI] Unlocalized strings for architecture module
[ALL_LANG][SAM CLI] Unlocalized strings for architecture module
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
Unspecified Unspecified
medium Severity medium (vote)
: Unspecified
: 6.0
Assigned To: Katello Bug Bin
SAM QE List
: i18n, Translation, Triaged
: 887100 887125 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-13 20:52 EST by Noriko Mizumoto
Modified: 2014-09-18 12:47 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-08 14:45:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noriko Mizumoto 2012-12-13 20:52:16 EST
Description of problem:
Unlocalized strings for domain module

Version-Release number of selected component (if applicable):
Subscription Asset Manager Version: 1.2.-6h.el6_3

How reproducible:
100%

Steps to Reproduce:

[root@i18nsamtest ~]# headpin architecture -h
Usage:  headpin <options> architecture <command>
Supported Commands:
	create         create an architecture
	delete         delete an architecture
	info           show details about an architecture
	list           list all known architectures
	update         update an architecture

Options:
  -h, --help  show this help message and exit

[root@i18nsamtest ~]# headpin architecture create -h
Usage:  headpin <options> architecture create <options>

Options:
  -h, --help    show this help message and exit
  --name=NAME   architecture name (required)
  -g            grep が使いやすい出力
  -v            詳細な構造化された出力
  -d DELIMITER  grep で認識できる出力内のコラム区切り記号、 -g オプションを付けた場合にのみ動作します
  --noheading   ヘッディングの出力を表示しません。出力を grep する場合に便利です。

# headpin architecture delete -h
# headpin architecture info -h
# headpin architecture list -h
# headpin architecture update -h



Actual results:
Unlocalized strings for architecture module.

Expected results:
All the strings should be localized.

Additional info:
Comment 1 Eunju, Kim 2012-12-14 00:00:45 EST
confirmed for ko-KR.
Comment 2 Hedda Peters 2012-12-14 00:22:52 EST
*** Bug 887125 has been marked as a duplicate of this bug. ***
Comment 3 Hedda Peters 2012-12-14 00:23:25 EST
confirmed for de-DE
Comment 4 Sam Friedmann 2012-12-14 00:46:39 EST
Confirmed for fr-FR.
Comment 5 Tom McKay 2012-12-18 09:12:26 EST
Mass moving i18n BZs to CFSE where they are also present
Comment 7 Lijun Li 2012-12-18 22:10:21 EST
Build: SAM-1.2-RHEL-6-20121211.n.0

katello-headpin-all.noarch 0:1.2.6-6h.el6_3 

[root@i18nsamtest ~]# headpin architecture -h
Usage:  headpin <options> architecture <command>
Supported Commands:
	create         create an architecture
	delete         delete an architecture
	info           show details about an architecture
	list           list all known architectures
	update         update an architecture

Options:
  -h, --help  show this help message and exit
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized.
[root@i18nsamtest ~]# headpin architecture create -h
Usage:  headpin <options> architecture create <options>

Options:
  -h, --help    show this help message and exit
  --name=NAME   architecture name (required)
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized.
  -g            grep が使いやすい出力
  -v            詳細な構造化された出力
  -d DELIMITER  grep で認識できる出力内のコラム区切り記号、 -g オプションを付けた場合にのみ動作します
  --noheading   ヘッディングの出力を表示しません。出力を grep する場合に便利です。
[root@i18nsamtest ~]# headpin architecture delete -h
Usage:  headpin <options> architecture delete <options>

Options:
  -h, --help    show this help message and exit
  --name=NAME   architecture name
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized.
  -g            grep が使いやすい出力
  -v            詳細な構造化された出力
  -d DELIMITER  grep で認識できる出力内のコラム区切り記号、 -g オプションを付けた場合にのみ動作します
  --noheading   ヘッディングの出力を表示しません。出力を grep する場合に便利です。
[root@i18nsamtest ~]# headpin architecture info -h
Usage:  headpin <options> architecture info <options>

Options:
  -h, --help    show this help message and exit
  --name=NAME   architecture name
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized.
  -g            grep が使いやすい出力
  -v            詳細な構造化された出力
  -d DELIMITER  grep で認識できる出力内のコラム区切り記号、 -g オプションを付けた場合にのみ動作します
  --noheading   ヘッディングの出力を表示しません。出力を grep する場合に便利です。
[root@i18nsamtest ~]# headpin architecture list -h
Usage:  headpin <options> architecture list

Options:
  -h, --help    show this help message and exit
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized.
  -g            grep が使いやすい出力
  -v            詳細な構造化された出力
  -d DELIMITER  grep で認識できる出力内のコラム区切り記号、 -g オプションを付けた場合にのみ動作します
  --noheading   ヘッディングの出力を表示しません。出力を grep する場合に便利です。
[root@i18nsamtest ~]# headpin architecture update -h
Usage:  headpin <options> architecture update <options>

Options:
  -h, --help       show this help message and exit
  --name=OLD_NAME  architecture name (required)
  --new_name=NAME  new name for the architecture (required)
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized.
  -g               grep が使いやすい出力
  -v               詳細な構造化された出力
  -d DELIMITER     grep で認識できる出力内のコラム区切り記号、 -g オプションを付けた場合にのみ動作します
  --noheading      ヘッディングの出力を表示しません。出力を grep する場合に便利です。
Comment 8 Lijun Li 2012-12-18 22:12:14 EST
*** Bug 887100 has been marked as a duplicate of this bug. ***
Comment 9 Miroslav Suchý 2013-02-12 04:37:17 EST
This will have to wait translation team just before next release of CFSE, which is not yet scheduled.
If you want this change in upstream sooner, you can help translate it here:
https://www.transifex.com/projects/p/katello/
Comment 10 Bryan Kearney 2014-01-08 14:45:36 EST
Closing all L10N bugs until we can do a full translation path through the code.

Note You need to log in before you can comment on or make changes to this bug.