Bug 887103 - [ALL_LANG][SAM CLI] Unlocalized strings for config_template module.
[ALL_LANG][SAM CLI] Unlocalized strings for config_template module.
Status: CLOSED DUPLICATE of bug 887080
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
x86_64 Linux
medium Severity medium (vote)
: Unspecified
: 6.0
Assigned To: Katello Bug Bin
SAM QE List
: Translation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-13 22:08 EST by Angela Garcia
Modified: 2014-09-18 12:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Consequence: Not all messages are localized Fix: Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-18 22:14:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Angela Garcia 2012-12-13 22:08:57 EST
Not all messages are localized

Filed from caserun (INSERT URL HERE)

Version-Release number of selected component (if applicable):
SAM-20121130.n.0

Steps to Reproduce: 

# headpin config_template -h

  * build_pxe_default

# headpin config_template build_pxe_default -h

  * Create

# headpin config_template create -h

  * Delete

# headpin config_template delete -h

  * Info

# headpin config_template info -h

  * List

# headpin config_template list -h

  * Update

# headpin config_template update -h



Actual results: 
#FIXME

Expected results:
Messages are localized.
Comment 1 Lijun Li 2012-12-13 23:04:40 EST
Build: SAM-1.2-RHEL-6-20121211.n.0

katello-headpin-all.noarch 0:1.2.6-6h.el6_3 

[root@i18nsamtest ~]# headpin config_template -h
Usage:  headpin <options> config_template <command>
Supported Commands:
	build_pxe_default build pxe default
	create         create config template
	delete         delete config template
	info           show information about a config template
	list           list config template
	update         update config template

Options:
  -h, --help  show this help message and exit
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized.
[root@i18nsamtest ~]# headpin config_template build_pxe_default -h
Usage:  headpin <options> config_template build_pxe_default <options>

Options:
  -h, --help    show this help message and exit
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized.
  -g            grep が使いやすい出力
  -v            詳細な構造化された出力
  -d DELIMITER  grep で認識できる出力内のコラム区切り記号、 -g オプションを付けた場合にのみ動作します
  --noheading   ヘッディングの出力を表示しません。出力を grep する場合に便利です。
[root@i18nsamtest ~]# headpin config_template create -h
Usage:  headpin <options> config_template create <options>

Options:
  -h, --help            show this help message and exit
  --name=NAME           テンプレート名 (必須)
  --template=TEMPLATE   template body (required)
  --snippet=SNIPPET     is it snippet?
  --audit_comment=AUDIT_COMMENT
                        Project-Id-Version:  Report-Msgid-Bugs-To:  POT-
                        Creation-Date: 2012-11-19 09:58-0500 PO-Revision-Date:
                        2012-10-09 09:55+0200 Last-Translator:  Language-Team:
                        American English <spacewalk-devel@redhat.com>
                        Language: ja MIME-Version: 1.0 Content-Type:
                        text/plain; charset=UTF-8 Content-Transfer-Encoding:
                        8bit Plural-Forms: nplurals=1; plural=0 X-Generator:
                        Lokalize 1.5
  --template_kind_id=TEMPLATE_KIND_ID
                        not relevant for snippet
  --template_combinations_attributes=TEMPLATE_COMBINATIONS_ATTRIBUTES
                        Array of template combinations (hostgroup_id,
                        environment_id)
  --operatingsystem_ids=OPERATINGSYSTEM_IDS
                        Array of operating systems ID to associate the
                        template with
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized.
  -g                    grep が使いやすい出力
  -v                    詳細な構造化された出力
  -d DELIMITER          grep で認識できる出力内のコラム区切り記号、 -g オプションを付けた場合にのみ動作します
  --noheading           ヘッディングの出力を表示しません。出力を grep する場合に便利です。
[root@i18nsamtest ~]# headpin config_template delete -h
Usage:  headpin <options> config_template delete <options>

Options:
  -h, --help    show this help message and exit
  --name=ID     config template id or name
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized.
  -g            grep が使いやすい出力
  -v            詳細な構造化された出力
  -d DELIMITER  grep で認識できる出力内のコラム区切り記号、 -g オプションを付けた場合にのみ動作します
  --noheading   ヘッディングの出力を表示しません。出力を grep する場合に便利です。
[root@i18nsamtest ~]# headpin config_template info -h
Usage:  headpin <options> config_template info <options>

Options:
  -h, --help    show this help message and exit
  --name=ID     config template id or name
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized.
  -g            grep が使いやすい出力
  -v            詳細な構造化された出力
  -d DELIMITER  grep で認識できる出力内のコラム区切り記号、 -g オプションを付けた場合にのみ動作します
  --noheading   ヘッディングの出力を表示しません。出力を grep する場合に便利です。
[root@i18nsamtest ~]# headpin config_template list -h
Usage:  headpin <options> config_template list <options>

Options:
  -h, --help       show this help message and exit
  --search=SEARCH  filter results
  --order=ORDER    sort results
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized.
  -g               grep が使いやすい出力
  -v               詳細な構造化された出力
  -d DELIMITER     grep で認識できる出力内のコラム区切り記号、 -g オプションを付けた場合にのみ動作します
  --noheading      ヘッディングの出力を表示しません。出力を grep する場合に便利です。
[root@i18nsamtest ~]# headpin config_template update -h
Usage:  headpin <options> config_template update <options>

Options:
  -h, --help            show this help message and exit
  --name=ID             template id or name
  --new_name=NAME       template new name
  --template=TEMPLATE   Project-Id-Version:  Report-Msgid-Bugs-To:  POT-
                        Creation-Date: 2012-11-19 09:58-0500 PO-Revision-Date:
                        2012-10-09 09:55+0200 Last-Translator:  Language-Team:
                        American English <spacewalk-devel@redhat.com>
                        Language: ja MIME-Version: 1.0 Content-Type:
                        text/plain; charset=UTF-8 Content-Transfer-Encoding:
                        8bit Plural-Forms: nplurals=1; plural=0 X-Generator:
                        Lokalize 1.5
  --snippet=SNIPPET     Project-Id-Version:  Report-Msgid-Bugs-To:  POT-
                        Creation-Date: 2012-11-19 09:58-0500 PO-Revision-Date:
                        2012-10-09 09:55+0200 Last-Translator:  Language-Team:
                        American English <spacewalk-devel@redhat.com>
                        Language: ja MIME-Version: 1.0 Content-Type:
                        text/plain; charset=UTF-8 Content-Transfer-Encoding:
                        8bit Plural-Forms: nplurals=1; plural=0 X-Generator:
                        Lokalize 1.5
  --audit_comment=AUDIT_COMMENT
                        Project-Id-Version:  Report-Msgid-Bugs-To:  POT-
                        Creation-Date: 2012-11-19 09:58-0500 PO-Revision-Date:
                        2012-10-09 09:55+0200 Last-Translator:  Language-Team:
                        American English <spacewalk-devel@redhat.com>
                        Language: ja MIME-Version: 1.0 Content-Type:
                        text/plain; charset=UTF-8 Content-Transfer-Encoding:
                        8bit Plural-Forms: nplurals=1; plural=0 X-Generator:
                        Lokalize 1.5
  --template_kind_id=TEMPLATE_KIND_ID
                        Project-Id-Version:  Report-Msgid-Bugs-To:  POT-
                        Creation-Date: 2012-11-19 09:58-0500 PO-Revision-Date:
                        2012-10-09 09:55+0200 Last-Translator:  Language-Team:
                        American English <spacewalk-devel@redhat.com>
                        Language: ja MIME-Version: 1.0 Content-Type:
                        text/plain; charset=UTF-8 Content-Transfer-Encoding:
                        8bit Plural-Forms: nplurals=1; plural=0 X-Generator:
                        Lokalize 1.5
  --template_combinations_attributes=TEMPLATE_COMBINATIONS_ATTRIBUTES
                        Project-Id-Version:  Report-Msgid-Bugs-To:  POT-
                        Creation-Date: 2012-11-19 09:58-0500 PO-Revision-Date:
                        2012-10-09 09:55+0200 Last-Translator:  Language-Team:
                        American English <spacewalk-devel@redhat.com>
                        Language: ja MIME-Version: 1.0 Content-Type:
                        text/plain; charset=UTF-8 Content-Transfer-Encoding:
                        8bit Plural-Forms: nplurals=1; plural=0 X-Generator:
                        Lokalize 1.5
  --operatingsystem_ids=OPERATINGSYSTEM_IDS
                        Project-Id-Version:  Report-Msgid-Bugs-To:  POT-
                        Creation-Date: 2012-11-19 09:58-0500 PO-Revision-Date:
                        2012-10-09 09:55+0200 Last-Translator:  Language-Team:
                        American English <spacewalk-devel@redhat.com>
                        Language: ja MIME-Version: 1.0 Content-Type:
                        text/plain; charset=UTF-8 Content-Transfer-Encoding:
                        8bit Plural-Forms: nplurals=1; plural=0 X-Generator:
                        Lokalize 1.5
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized.
  -g                    grep が使いやすい出力
  -v                    詳細な構造化された出力
  -d DELIMITER          grep で認識できる出力内のコラム区切り記号、 -g オプションを付けた場合にのみ動作します
  --noheading           ヘッディングの出力を表示しません。出力を grep する場合に便利です。
Comment 2 Tom McKay 2012-12-18 09:11:49 EST
Mass moving i18n BZs to CFSE where they are also present
Comment 4 Lijun Li 2012-12-18 22:14:56 EST

*** This bug has been marked as a duplicate of bug 887080 ***

Note You need to log in before you can comment on or make changes to this bug.