Bug 88718 - Kdevelop cannot create a QT SDI project
Kdevelop cannot create a QT SDI project
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdevelop (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
: 88719 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-12 11:19 EDT by John Alsop
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-10 11:28:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Alsop 2003-04-12 11:19:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.0.3705)

Description of problem:
I have installed RedHat 9.0 on two computers and the results are the same.  
The first time I use kdevelop, it goes through its setup (yes, there are still 
documentation problems, but we'll save that for another bug report).  Next, 
when I try to create a QT SDI project, I get this error indication in the 
lower pane of the ApplicationWizard/Process window:

configure.in:63: error: m4_popdef: undefined macro AC_Dest
autoconf/status.m4:844: AC_CONFIG_FILES is expanded from...
configure.in:63: the top level
autom4te: /usr/bin/m4 failed with exit status: 1
make[1]: ***[cvs] Error 1
make: ***[all] Error 2

A search of the database does not turn up any information on this, yet I think 
I have heard of it from others.  Well, anyway, its back.

Version-Release number of selected component (if applicable):
kdevelop 2.1.5 using KDE 3.1-10 RedHat

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1.Install RedHat 9.0
2.Run kdevelop
3.Try to create a QT SDI project
    

Actual Results:  I got the error reported in "description" above.  No Makefile 
was generated.

Expected Results:  It should have make a "bare bones" project with a Makefile.



Additional info:
Comment 1 Ngo Than 2003-05-08 11:52:36 EDT
*** Bug 88719 has been marked as a duplicate of this bug. ***
Comment 2 John Alsop 2003-05-23 17:20:25 EDT
It is entirely reproduceable -- it happens every time.
Comment 3 Ngo Than 2003-05-26 15:18:12 EDT
yes, i can reproduce this problem. it seems that kdevelop does not work with
autoconf version in RHL 9.
Comment 4 Ngo Than 2003-06-10 11:28:05 EDT
it's fixed in kdevelop-2.1.5-9, which is available in rawhide.
For RHL 9 it needs to be rebuild again.

Note You need to log in before you can comment on or make changes to this bug.