Bug 887501 - Qt: webkit Designer plug-in missing
Qt: webkit Designer plug-in missing
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-15 13:12 EST by Frank Büttner
Modified: 2013-01-24 16:57 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-17 07:42:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Frank Büttner 2012-12-15 13:12:49 EST
Description of problem:
The plug-in for the qt designer is missing.
missing file:
/usr/lib64/qt4/plugins/designer/libqwebview.so


Version-Release number of selected component (if applicable):
qtwebkit-devel-2.2.2-1.fc17.x86_64

How reproducible:



Steps to Reproduce:
1. install qtwebkit-devel and qt-devel
2. run designer-qt4

  
Actual results:
the designer plug-in is missing


Expected results:
that the plug-in will be visible in the designer

Additional info:
Comment 1 Rex Dieter 2012-12-15 14:21:54 EST
webkit designer plugin hasn't been included (upstream) for a long time... at least not since we started using the standalone (unbundled from qt) version of qtwebkit
Comment 2 Rex Dieter 2012-12-15 20:49:51 EST
actually, it would appear we could still build this and provide as some sort of subpkg from qt.
Comment 3 Rex Dieter 2012-12-16 17:25:07 EST
%changelog
* Sun Dec 16 2012 Rex Dieter <rdieter@fedoraproject.org> 1:4.8.4-2
- -designer-plugin-webkit subpkg (#887501)
Comment 4 Rex Dieter 2012-12-17 07:42:15 EST
this is now fixed in rawhide, and will be included in the next semi-regularly scheduled qt bugfix update.

Frank,
Unless... is there some urgency that you need this sooner rather than later?  If so, please re-open...
Comment 5 Fedora Update System 2013-01-04 10:36:13 EST
qt-4.8.4-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/qt-4.8.4-4.fc18
Comment 6 Fedora Update System 2013-01-04 10:47:53 EST
qt-4.8.4-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/qt-4.8.4-4.fc17
Comment 7 Fedora Update System 2013-01-04 10:51:48 EST
qt-4.8.4-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/qt-4.8.4-4.fc16
Comment 8 Fedora Update System 2013-01-05 15:11:29 EST
qt-4.8.4-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2013-0277/qt-4.8.4-5.fc17
Comment 9 Fedora Update System 2013-01-12 10:08:19 EST
qt-4.8.4-6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-01-22 20:40:04 EST
qt-4.8.4-6.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2013-01-24 16:57:54 EST
qt-4.8.4-6.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.