This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 887552 - 3.2 Upgrade: version lock contents are lost after upgrade from 3.0 to 3.1
3.2 Upgrade: version lock contents are lost after upgrade from 3.0 to 3.1
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity urgent
: ---
: 3.2.0
Assigned To: Moran Goldboim
Pavel Stehlik
integration
: ZStream
Depends On:
Blocks: 888223
  Show dependency treegraph
 
Reported: 2012-12-16 05:16 EST by Yaniv Kaul
Modified: 2015-09-22 09 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 888223 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Yaniv Kaul 2012-12-16 05:16:43 EST
Description of problem:
On rhevm-3 (QA's production setup) which was upgraded from 3.0.7 to 3.1 (SI24), in several iterations (due to multiple upgrade failures which required rollbacks), there is no version lock contents whatsoever:


[root@rhevm-3 ~]# cat /etc/yum/pluginconf.d/versionlock.conf
[main]
enabled = 1
locklist = /etc/yum/pluginconf.d/versionlock.list
#  Uncomment this to lock out "upgrade via. obsoletes" etc. (slower)
# follow_obsoletes = 1
[root@rhevm-3 ~]# cat /etc/yum/pluginconf.d/versionlock.list
[root@rhevm-3 ~]# ls -l /etc/yum/pluginconf.d/versionlock.list
-rw-r--r--. 1 root root 0 Nov 26 10:22 /etc/yum/pluginconf.d/versionlock.list


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Itamar Heim 2012-12-16 06:47:07 EST
didn't see this on another environment.
yaniv - was the upgrade maybe stopped during the phase it installs the new rpms?
moran - shouldn't upgrade fix this list even if it wasn't there in the begining.
Comment 3 Yaniv Kaul 2012-12-18 01:54:44 EST
How do we reproduce it? While it happened, I'm not sure it happens all the time.
Comment 4 Moran Goldboim 2012-12-18 02:10:37 EST
(In reply to comment #3)
> How do we reproduce it? While it happened, I'm not sure it happens all the
> time.

happens on 3.0->3.1 upgrade, workaround is a following 3.1->3.1.z upgrade.
Comment 5 Yaniv Kaul 2012-12-18 02:36:17 EST
(In reply to comment #4)
> (In reply to comment #3)
> > How do we reproduce it? While it happened, I'm not sure it happens all the
> > time.
> 
> happens on 3.0->3.1 upgrade, workaround is a following 3.1->3.1.z upgrade.

I assume via rhevm-upgrade, as there's no versionlock?
Comment 6 Alex Lourie 2012-12-18 02:58:40 EST
(In reply to comment #5)
> 
> I assume via rhevm-upgrade, as there's no versionlock?

Yes. The rhevm-upgrade will restore the versionlock list.
Comment 10 Itamar Heim 2013-06-11 04:55:18 EDT
3.2 has been released
Comment 11 Itamar Heim 2013-06-11 04:55:21 EDT
3.2 has been released
Comment 12 Itamar Heim 2013-06-11 04:55:31 EDT
3.2 has been released
Comment 13 Itamar Heim 2013-06-11 04:58:18 EDT
3.2 has been released
Comment 14 Itamar Heim 2013-06-11 05:27:51 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.