Bug 887635 - SELinux is preventing /usr/bin/gxine from 'write' accesses on the sock_file /home/brandon0/.config/gxine/socket.
Summary: SELinux is preventing /usr/bin/gxine from 'write' accesses on the sock_file /...
Keywords:
Status: CLOSED DUPLICATE of bug 887632
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 17
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e99dbb4471ab0503869e9a214d6...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-16 21:08 UTC by bm_boris
Modified: 2012-12-17 09:02 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-17 09:02:31 UTC
Type: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-12-16 21:08 UTC, bm_boris
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-12-16 21:09 UTC, bm_boris
no flags Details

Description bm_boris 2012-12-16 21:08:50 UTC
Additional info:
libreport version: 2.0.18
kernel:         3.6.9-2.fc17.x86_64

description:
:SELinux is preventing /usr/bin/gxine from 'write' accesses on the sock_file /home/brandon0/.config/gxine/socket.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that gxine should be allowed write access on the socket sock_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep gxine /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:config_home_t:s0
:Target Objects                /home/brandon0/.config/gxine/socket [ sock_file ]
:Source                        gxine
:Source Path                   /usr/bin/gxine
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           gxine-0.5.907-2.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-161.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.9-2.fc17.x86_64 #1 SMP Tue Dec
:                              4 13:26:04 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    2012-12-16 08:13:48 CST
:Last Seen                     2012-12-16 08:14:59 CST
:Local ID                      32459196-fb41-457b-8f30-719e8bdcecf2
:
:Raw Audit Messages
:type=AVC msg=audit(1355667299.790:781): avc:  denied  { write } for  pid=18658 comm="gxine" name="socket" dev="dm-3" ino=11667783 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:config_home_t:s0 tclass=sock_file
:
:
:type=SYSCALL msg=audit(1355667299.790:781): arch=x86_64 syscall=connect success=no exit=EACCES a0=11 a1=7fff7c13a2e0 a2=6e a3=7fff7c13a2e2 items=0 ppid=1 pid=18658 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=1 comm=gxine exe=/usr/bin/gxine subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: gxine,mozilla_plugin_t,config_home_t,sock_file,write
:
:audit2allow
:
:#============= mozilla_plugin_t ==============
:allow mozilla_plugin_t config_home_t:sock_file write;
:
:audit2allow -R
:
:#============= mozilla_plugin_t ==============
:allow mozilla_plugin_t config_home_t:sock_file write;
:

Comment 1 bm_boris 2012-12-16 21:08:57 UTC
Created attachment 664539 [details]
File: type

Comment 2 bm_boris 2012-12-16 21:09:03 UTC
Created attachment 664540 [details]
File: hashmarkername

Comment 3 Miroslav Grepl 2012-12-17 09:02:31 UTC

*** This bug has been marked as a duplicate of bug 887632 ***


Note You need to log in before you can comment on or make changes to this bug.