Bug 887997 - [it] pofilter newlines test failed on msgid="Error subscribing: %s"
[it] pofilter newlines test failed on msgid="Error subscribing: %s"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
IDM QE LIST
: Translation
Depends On:
Blocks: 771481 888457
  Show dependency treegraph
 
Reported: 2012-12-17 14:32 EST by John Sefler
Modified: 2013-02-21 04:04 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 04:04:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-12-17 14:32:47 EST
Description of problem:

# (pofilter) newlines: Different line endings
msgid "Error subscribing: %s"
msgstr ""
"Errore di sottoscrizione: %s\n"
"\n"
"\t"
^^^^ TOO MUCH WHITE SPACE AT THE END OF THIS fr TRANSLATION

EXPECTED THE FOLLOWING TRANSLATION:
msgstr "Errore di sottoscrizione: %s"

Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.15-1.el6.x86_64


Additional info:
Comment 2 Hedda Peters 2012-12-17 18:32:05 EST
Our it-IT translator is now on annual leave until early January. 

However, as this is a simple white space error I have taken care of this on his behalf: 
Error is fixed in it-IT translation in https://translate.zanata.org/zanata/iteration/view/subscription-manager/1.1.X.
Comment 4 John Sefler 2012-12-19 15:28:39 EST
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.18-1.el6.x86_64


> # (pofilter) newlines: Different line endings
> msgid ""
> "Did not receive a completed unregistration message from RHN Classic for system %s.\n"
> "Please investigate on the Customer Portal at https://access.redhat.com."
msgstr "Non è stato ricevuto alcun messaggio di deregistrazione da RHN Classic per il sistema %s. Consultare il Portale clienti su https://access.redhat.com."

^ PLEASE INSERT A "\n" CHARACTER AT THE END OF THE FIRST SENTENCE.


> # (pofilter) newlines: Different line endings
> msgid ""
> "We have detected that you have multiple service levels on various products. Please select how you\n"
> "want them assigned."
> msgstr "Abbiamo rilevato che sei in possesso di livelli di servizio multipli su vari prodotti. Selezionare come assegnarli."

^ PLEASE INSERT A "\n" CHARACTER AT THE END OF THE FIRST SENTENCE.


Moving back to NEW/FailedQA status.
Comment 5 Hedda Peters 2012-12-19 19:29:28 EST
Fixed in it-IT translation in https://translate.zanata.org/zanata/iteration/view/subscription-manager/1.1.X.
Comment 6 Adrian Likins 2013-01-04 13:15:19 EST
fixed upstream, should be in 1.1.19
Comment 7 John Sefler 2013-01-08 16:20:15 EST
Verifying Version...
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.20-1.el6.x86_64


[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/it/LC_MESSAGES/rhsm.mo > /usr/share/locale/it/LC_MESSAGES/rhsm.po
[root@jsefler-6 ~]# pofilter -t newlines /usr/share/locale/it/LC_MESSAGES/rhsm.po
processing 1 files...
[###########################################] 100%
[root@jsefler-6 ~]# 

VERIFIED: pofilter newlines test is now passing for LANG=it



[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/it/LC_MESSAGES/rhsm.mo | grep -A5 -B1 "Did not receive"
msgid ""
"Did not receive a completed unregistration message from RHN Classic for system %s.\n"
"Please investigate on the Customer Portal at https://access.redhat.com."
msgstr ""
"Non è stato ricevuto alcun messaggio di deregistrazione da RHN Classic per il sistema %s.\n"
"Consultare il Portale clienti su https://access.redhat.com."

[root@jsefler-6 ~]# 
[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/it/LC_MESSAGES/rhsm.mo | grep -A5 -B1 "We have detected"
msgid ""
"We have detected that you have multiple service levels on various products. Please select how you\n"
"want them assigned."
msgstr ""
"Abbiamo rilevato che sei in possesso di livelli di servizio multipli su vari prodotti.\n"
"Selezionare come assegnarli."

[root@jsefler-6 ~]# 

VERIFIED: newline characters are now well placed
Comment 9 errata-xmlrpc 2013-02-21 04:04:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.