Bug 888091 - glance-manage does not list possible commands
glance-manage does not list possible commands
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-glance (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
low Severity low
: snapshot3
: 2.1
Assigned To: John Bresnahan
Yaniv Kaul
: Triaged
: 889321 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-17 19:34 EST by John Bresnahan
Modified: 2016-04-26 14:58 EDT (History)
5 users (show)

See Also:
Fixed In Version: openstack-glance-2012.2.3-1.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-05 13:30:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Bresnahan 2012-12-17 19:34:14 EST
glance-manage does not list the possible commands when given --help or given an unknown command.  keystone-manage, which is a similar program, does list the possible commands.

How reproducible:

glance-manage --help
glance-manage XXX
  
Actual results:

$ glance-manage xxx
ERROR: unrecognized command 'xxx'


Expected results:

The results from keystone-manage are:

$ keystone-manage xxx

Available commands:
                db_sync: Sync the database.
  export_legacy_catalog: Export the service catalog from a legacy database.
          import_legacy: Import a legacy database.
       import_nova_auth: Import a dump of nova auth data into keystone.
              pki_setup: Set up Key pairs and certificates for token signing and
                         verification.
Unknown command: xxx
Comment 2 Eoghan Glynn 2012-12-20 11:27:39 EST
Looks like a kosher expectation.
Comment 3 Dan Prince 2012-12-20 15:41:35 EST
*** Bug 889321 has been marked as a duplicate of this bug. ***
Comment 7 Yaniv Kaul 2013-02-05 06:51:41 EST
Re-opening:
[root@ykaul-os-glance ~]# rpm -qa |grep glance
python-glance-2012.2.1-5.el6ost.noarch
python-glanceclient-0.5.1-1.el6.noarch
openstack-glance-2012.2.1-5.el6ost.noarch

[root@ykaul-os-glance ~]# glance-manage xxx
ERROR: unrecognized command 'xxx'
Comment 8 Alan Pevec 2013-02-05 09:40:06 EST
It works w/o arguments, but yeah should be made consistent in all upstream projects:
# glance-manage 
Usage: glance-manage [options] [downgrade|db_sync|upgrade|db_version|version_control]
Comment 12 Kashyap Chamarthy 2013-02-19 03:34:05 EST
VERIFIED.

Version info:
#-------------------------------------------------#
[tuser1@interceptor ~]$ rpm -qa | grep -i glance
python-glanceclient-0.5.1-2.el6ost.noarch
python-glance-2012.2.3-1.el6ost.noarch
openstack-glance-2012.2.3-1.el6ost.noarch
[tuser1@interceptor ~]$ 
#-------------------------------------------------#
[tuser1@interceptor ~]$ cat /etc/redhat-release ; arch
Red Hat Enterprise Linux Server release 6.4 (Santiago)
x86_64
[tuser1@interceptor ~]$ 


Verification info:
#-------------------------------------------------#
[tuser1@interceptor ~]$ glance-manage --help
Usage: glance-manage [options] [downgrade|db_sync|upgrade|db_version|version_control]

Options:
  --version             show program's version number and exit
  -h, --help            show this help message and exit
  --default_log_levels=DEFAULT_LOG_LEVELS
                        list of logger=LEVEL pairs
  -v, --verbose         Print more verbose output
  --noverbose           The inverse of --verbose
  --sql_max_retries=SQL_MAX_RETRIES
  --enable_v2_api       Deploy the v2 OpenStack Images API.
  --noenable_v2_api     The inverse of --enable_v2_api
  --db_auto_create
.
.
.
.
.
.
#-------------------------------------------------#
Comment 14 errata-xmlrpc 2013-03-05 13:30:12 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0593.html

Note You need to log in before you can comment on or make changes to this bug.