Bug 888098 - SQLAlchemy warning during Nova db sync
Summary: SQLAlchemy warning during Nova db sync
Keywords:
Status: CLOSED DUPLICATE of bug 849231
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-utils
Version: 2.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2.1
Assignee: RHOS Maint
QA Contact: Yaniv Kaul
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-18 00:51 UTC by Russell Bryant
Modified: 2013-07-04 02:55 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-19 20:06:47 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Russell Bryant 2012-12-18 00:51:29 UTC
Description of problem:

When setting up the nova db, you get a SQLAlchemy warning.  This needs to be silenced so that it does not cause unnecessary alarm for users.  It looks like it's a real problem.

# openstack-db --init --service nova
Please enter the password for the 'root' MySQL user: 
Verified connectivity to MySQL.
Creating 'nova' database.
Asking openstack-nova to sync the database.
2012-12-17 19:45:05 15743 WARNING nova.common.deprecated [-] <type 'NoneType'> being associated with <class 'sqlalchemy.schema.Column'> object after the <class 'sqlalchemy.schema.Column'> has already been used in a SQL generation; previously generated constructs may contain stale state.
Complete!



Version-Release number of selected component (if applicable):


[root@rhel ~(keystone_username)]# rpm -qa | grep nova
python-novaclient-2.10.0-1.el6ost.noarch
openstack-nova-common-2012.2.1-2.el6ost.noarch
openstack-nova-compute-2012.2.1-2.el6ost.noarch
openstack-nova-scheduler-2012.2.1-2.el6ost.noarch
python-nova-2012.2.1-2.el6ost.noarch
openstack-nova-console-2012.2.1-2.el6ost.noarch
openstack-nova-api-2012.2.1-2.el6ost.noarch
openstack-nova-volume-2012.2.1-2.el6ost.noarch
openstack-nova-cert-2012.2.1-2.el6ost.noarch
openstack-nova-2012.2.1-2.el6ost.noarch
openstack-nova-network-2012.2.1-2.el6ost.noarch
openstack-nova-objectstore-2012.2.1-2.el6ost.noarch

Comment 2 Martin Magr 2012-12-18 15:09:09 UTC
This happened to me too during glance db sync:
[para@virtual-rhel-beta ~(keystone_test)]$ sudo openstack-db --init --service glance
Please enter the password for the 'root' MySQL user: 
Verified connectivity to MySQL.
Creating 'glance' database.
Asking openstack-glance to sync the database.
/usr/lib/python2.6/site-packages/migrate/changeset/schema.py:554: SAWarning: <type 'NoneType'> being associated with <class 'sqlalchemy.schema.Column'> object after the <class 'sqlalchemy.schema.Column'> has already been used in a SQL generation; previously generated constructs may contain stale state.
  self.table = None
/usr/lib/python2.6/site-packages/glance/db/sqlalchemy/migrate_repo/versions/003_add_disk_format.py:46: SADeprecationWarning: useexisting is deprecated.  Use extend_existing.
  useexisting=True)
Complete!

[para@virtual-rhel-beta ~(keystone_test)]$ rpm -qa openstack-utils
openstack-utils-2012.2-6.el6.noarch

Comment 3 Alan Pevec 2012-12-19 20:06:47 UTC

*** This bug has been marked as a duplicate of bug 849231 ***


Note You need to log in before you can comment on or make changes to this bug.