Bug 88810 - KEY set incorrectly for wireless cards using multiple encryption keys
KEY set incorrectly for wireless cards using multiple encryption keys
Status: CLOSED DUPLICATE of bug 88566
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-14 10:48 EDT by Keith Winston
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith Winston 2003-04-14 10:48:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
When adding a wireless card configuration, I used redhat-config-network /
wireless device configuration / wireless settings tab, and defined the settings
for my wireless network, including the encryption key (which is hex).  The
redhat-config-network writes the configuration to
/etc/sysconfig/networking/devices/ifcfg-eth1 and saves the KEY value as either a
string or hex value.

The Orinoco Silver wireless card supports 4 key values and you normally specify
which key to use by following the key value with the key number in brackets. 
For example, to specify key 2, use FFFF-FFFF-FF [2].  This syntax worked
correctly in Red Hat 8.  In Red Hat 9, the key above gets converted to a string
value and doesn't work (it gets stored as KEY='s:FFFF-FFFF-FF [2]').  The
brackets seems to be throwing it off.  If I enter it without the space, it still
stores it as a string.  If I enter 0xFFFF-FFFF-FF [2], it still converts it to a
string of KEY='s:0xFFFF-FFFF-FF [2]'.

The only way I can get it to work is to manually edit the ifcfg-eth1 file and
set the key to 'FFFF-FFFF-FF [2]'.  Then, it works normally.

The wireless tab in redhat-config-network should allow you enter a hex key and
specify which key to use without converting the key value to a string.


Version-Release number of selected component (if applicable):
redhat-config-network-tui-1.2.0-2

How reproducible:
Always

Steps to Reproduce:
1. start redhat-config-network
2. add a new wireless pcmcia card definition, lucent orinoco silver
3. set the encryption key to a hex value using key [2], for example,
FFFF-FFFF-FF [2]
4. the incorrect key value will be stored in the card configuration file (it
will be converted to a string).
    

Actual Results:  It created a string key instead of a hex encryption key value.

Expected Results:  It should have stored a hex encryption key value.

Additional info:

redhat-config-network worked correctly in Red Hat 8.
Comment 1 Harald Hoyer 2003-04-14 11:32:59 EDT

*** This bug has been marked as a duplicate of 88566 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:52:40 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.