Bug 888326 - graphviz-ocaml-0:2.28.0-23.el7 cannot be installed because ocaml has been upgraded
Summary: graphviz-ocaml-0:2.28.0-23.el7 cannot be installed because ocaml has been upg...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: graphviz
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: Miroslav Hradílek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-18 13:55 UTC by Petr Pisar
Modified: 2014-06-11 11:07 UTC (History)
1 user (show)

Fixed In Version: graphviz-2.28.0-24.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-11 11:07:02 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Petr Pisar 2012-12-18 13:55:36 UTC
graphviz-ocaml-0:2.28.0-23.el7 run-requires exact version of ocaml (ocaml(runtime) = 4.00.0) but this one does not exist in RHEL-7 anymore because ocaml has been rebased to 4.00.1:

$ repoquery --repoid=rhel-7 --whatprovides 'ocaml(runtime)'
ocaml-runtime-0:4.00.1-1.el7.i686
ocaml-runtime-0:4.00.1-1.el7.x86_64

$ repoquery --repoid=rhel-7 --provides ocaml-runtime-0:4.00.1-1.el7.i686 |grep 'ocaml(runtime)'
ocaml(runtime) = 4.00.1

Please rebuild graphviz against current ocaml.

Comment 2 Jaroslav Škarvada 2012-12-19 11:27:45 UTC
(In reply to comment #0)
Thanks, fixed in graphviz-2.28.0-24.el7


Note You need to log in before you can comment on or make changes to this bug.