Bug 888394 - SAM 1.2 installation in a machine with Java 1.7 automatically installs Java 1.6
SAM 1.2 installation in a machine with Java 1.7 automatically installs Java 1.6
Status: CLOSED WONTFIX
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.2
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Katello Bug Bin
SAM QE List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-18 11:05 EST by sthirugn@redhat.com
Modified: 2012-12-19 10:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-19 10:10:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sthirugn@redhat.com 2012-12-18 11:05:49 EST
Description of problem:
Trying to install SAM 1.2 in a RHEL machine with Java 1.7 automatically installs Java 1.6

Version-Release number of selected component (if applicable):
* candlepin-0.7.19-1.el6_3.noarch
* candlepin-tomcat6-0.7.19-1.el6_3.noarch
* elasticsearch-0.19.9-5.el6_3.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.2.1-1h.el6_3.noarch
* katello-cli-1.2.4-4h.el6_3.noarch
* katello-cli-common-1.2.4-4h.el6_3.noarch
* katello-common-1.2.6-6h.el6_3.noarch
* katello-configure-1.2.3-1h.el6_3.noarch
* katello-glue-candlepin-1.2.6-6h.el6_3.noarch
* katello-headpin-1.2.6-6h.el6_3.noarch
* katello-headpin-all-1.2.6-6h.el6_3.noarch
* katello-selinux-1.2.1-1h.el6_3.noarch
* thumbslug-0.0.27-1.el6_3.noarch
* thumbslug-selinux-0.0.27-1.el6_3.noarch


How reproducible:
All times

Steps to Reproduce:
1. Register and subscribe a RHEL 6.x base system
2. Manually uninstall Java 1.6 from the machine
3. Install Java 1.7 
# yum -y install java-1.7.0-openjdk java-1.7.0-openjdk-devel
4. Install SAM 1.2 from compose
5. Check the avaialable java versions in the machine after SAM 1.2 installation is completed
# rpm -qa | grep java
  
Actual results:
Java 1.6 is present (please see below the results of # rpm -qa | grep java)

java-1.7.0-openjdk-devel-1.7.0.9-2.3.3.2.el6_3.x86_64
jboss-javaee-poms-5.0.1-2.9.ep5.el6.noarch
tzdata-java-2012i-2.el6.noarch
java-1.6.0-openjdk-1.6.0.0-1.50.1.11.5.el6_3.x86_64 <-------------------
java_cup-0.10k-5.el6.x86_64
java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64
sigar-java-1.6.5-0.9.git58097d9h.el6_3.x86_64
snappy-java-1.0.4-2.el6_3.x86_64
glassfish-javamail-1.4.4-6_redhat_1.ep6.el6.1.noarch
java-1.7.0-openjdk-1.7.0.9-2.3.3.2.el6_3.x86_64


Expected results:
Java 1.6 should not be present

Additional info:
Tried the following command but did not find anything
# rpm -q --whatrequires java-1.7.0
Comment 1 sthirugn@redhat.com 2012-12-18 11:12:48 EST
This bug was found while retesting BZ https://bugzilla.redhat.com/show_bug.cgi?id=882996
Comment 2 Bryan Kearney 2012-12-18 15:56:50 EST
This is due to the fact that in fedora the java-1.7.0-openjdk package provided

java = 1:1.7.0

but in RHEL is it

java7 = 1:1.7.0

Note You need to log in before you can comment on or make changes to this bug.