This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 888461 - Failed snapshot leaves task_state in 'image_snapshot'
Failed snapshot leaves task_state in 'image_snapshot'
Status: CLOSED DUPLICATE of bug 902293
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity unspecified
: snapshot4
: 2.1
Assigned To: Nikola Dipanov
Yaniv Kaul
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-18 13:21 EST by Russell Bryant
Modified: 2016-04-22 01:01 EDT (History)
2 users (show)

See Also:
Fixed In Version: openstack-nova-2012.2.3-1.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-18 07:59:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Russell Bryant 2012-12-18 13:21:58 EST
Description of problem:

After a snapshot attempted failed (due to bug 888455 in python-glanceclient), the instance in nova was left in a bad state.  The task_state was stuck in 'image_snapshot'.


Version-Release number of selected component (if applicable):

python-novaclient-2.10.0-1.el6ost.noarch
openstack-nova-common-2012.2.1-2.el6ost.noarch
openstack-nova-compute-2012.2.1-2.el6ost.noarch
openstack-nova-scheduler-2012.2.1-2.el6ost.noarch
openstack-nova-novncproxy-0.4-2.el6.noarch
python-nova-2012.2.1-2.el6ost.noarch
openstack-nova-console-2012.2.1-2.el6ost.noarch
openstack-nova-api-2012.2.1-2.el6ost.noarch
openstack-nova-volume-2012.2.1-2.el6ost.noarch
openstack-nova-cert-2012.2.1-2.el6ost.noarch
openstack-nova-2012.2.1-2.el6ost.noarch
openstack-nova-network-2012.2.1-2.el6ost.noarch
openstack-nova-objectstore-2012.2.1-2.el6ost.noarch
openstack-glance-2012.2.1-1.el6ost.noarch
python-glance-2012.2.1-1.el6ost.noarch
python-glanceclient-0.5.1-1.el6.noarch



How reproducible:

Every time.


Steps to Reproduce / Results:

# nova image-create 7cdab80a-286b-4bab-be94-ad35ae481b7f "El Niño"
ERROR: The server has either erred or is incapable of performing the requested operation. (HTTP 500) (Request-ID: req-76ff5c85-37a2-4cd9-bfc6-5e334cee6656)

... wait a long time ...

[root@rhel ~(keystone_username)]# nova image-create 7cdab80a-286b-4bab-be94-ad35ae481b7f "snapshot 1"
ERROR: Cannot 'createImage' while instance is in task_state image_snapshot (HTTP 409) (Request-ID: req-34aaea9e-6528-4cf1-b6ba-aebd41186f95)
Comment 2 Nikola Dipanov 2013-02-18 07:59:03 EST
I am closing this as a duplicate of the bug 902293.

The fix has been released and is in the latest build (at the time of this writing that is openstack-nova-2012.2.3-1.el6ost)

*** This bug has been marked as a duplicate of bug 902293 ***

Note You need to log in before you can comment on or make changes to this bug.