Bug 888553 - quantum instructions for openvswitch need service started, and sudo
quantum instructions for openvswitch need service started, and sudo
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Getting_Started_Guide (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stephen Gordon
ecs-bugs
: Documentation, Triaged
: 888772 904269 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-18 16:23 EST by Eric Harney
Modified: 2013-02-21 15:30 EST (History)
4 users (show)

See Also:
Fixed In Version: Red_Hat_OpenStack_Preview-Getting_Started_Guide-2-web-en-US-1.0-11.el6eng
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 15:30:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Harney 2012-12-18 16:23:27 EST
Description of problem:
Using the Quantum instructions in the Getting Started guide tells you to run "ovs-vsctl add-br br-int".  This fails because the openvswitch service has not been started yet.  The ovs-vsctl command also seems to require sudo, but is not shown to use sudo in the guide.

Version-Release number of selected component (if applicable):
https://access.redhat.com/knowledge/docs/en-US/Red_Hat_OpenStack_Preview/2/html/Getting_Started_Guide/chapter-Quantum.html  on Dec 18

 
Actual results:
[eharney@rhel64b ~(keystone_username)]$ ovs-vsctl add-br br-int
2012-12-18T21:13:52Z|00002|stream_unix|ERR|/var/run/openvswitch/db.sock: connection failed (No such file or directory)
2012-12-18T21:13:52Z|00003|reconnect|WARN|unix:/var/run/openvswitch/db.sock: connection attempt failed (No such file or directory)
...
^C2012-12-18T21:13:58Z|00008|fatal_signal|WARN|terminating with signal 2 (Interrupt)

[eharney@rhel64b ~(keystone_username)]$ sudo service openvswitch status
ovsdb-server is not running
ovs-vswitchd is not running
[eharney@rhel64b ~(keystone_username)]$ sudo service openvswitch start
Inserting openvswitch module                               [  OK  ]
/etc/openvswitch/conf.db does not exist ... (warning).
Creating empty database /etc/openvswitch/conf.db           [  OK  ]
Starting ovsdb-server                                      [  OK  ]
Configuring Open vSwitch system IDs                        [  OK  ]
Starting ovs-vswitchd                                      [  OK  ]
[eharney@rhel64b ~(keystone_username)]$ ovs-vsctl add-br br-int
2012-12-18T21:14:07Z|00002|stream_unix|ERR|/var/run/openvswitch/db.sock: connection failed (Permission denied)
2012-12-18T21:14:07Z|00003|reconnect|WARN|unix:/var/run/openvswitch/db.sock: connection attempt failed (Permission denied)
...
^C2012-12-18T21:14:11Z|00008|fatal_signal|WARN|terminating with signal 2 (Interrupt)

[eharney@rhel64b ~(keystone_username)]$ sudo ovs-vsctl add-br br-int


Expected results:
No errors

Additional info:
Need to add "sudo service openvswitch start", "sudo chkconfig openvswitch on", and sudo to the ovs-vsctl command.
Comment 2 Stephen Gordon 2013-01-25 15:57:36 EST
commit 3088caae08a1ca2c28c14d2b5be58b3260b37557

BZ#888553 - Start openvswitch service and use sudo.
    
Previously instructions in Quantum chapter:
    
- Skipped starting of openvswitch service (required by ovs-vsctl
  command).
- Did not note need to run ovs-vsctl using sudo.
Comment 3 Stephen Gordon 2013-01-25 16:47:08 EST
Fixed in Red_Hat_OpenStack_Preview-Getting_Started_Guide-2-web-en-US-1.0-11.el6eng
Comment 5 Stephen Gordon 2013-01-26 13:12:12 EST
*** Bug 904269 has been marked as a duplicate of this bug. ***
Comment 6 Stephen Gordon 2013-01-26 15:51:30 EST
*** Bug 888772 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.