Bug 888708 - (qemu) ? drive_add result do not include iops,iops_wr,iops_rd,bps,bps_wr,bps_rd inofs
(qemu) ? drive_add result do not include iops,iops_wr,iops_rd,bps,bps_wr,bps_...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Kevin Wolf
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-19 04:44 EST by juzhang
Modified: 2013-12-27 12:02 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-27 12:02:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description juzhang 2012-12-19 04:44:35 EST
Description of problem:
(qemu) ? drive_add result do not include iops,iops_wr,iops_rd,bps,bps_wr,bps_rd inofs

Version-Release number of selected component (if applicable):
Host Kernel
#uname -r
3.6.0-0.29.el7.x86_64
qemu-kvm version
qemu-kvm-1.2.0-20.el7.x86_64


How reproducible:
100%

Steps to Reproduce:
1.Boot guest
#/usr/libexec/qemu-kvm -cpu Opteron_G3 -m 2048 -smp 2,sockets=1,cores=2,threads=1 -enable-kvm -name rhel64 -smbios type=1,manufacturer='Red Hat',product='RHEV Hypervisor',version=el6,serial=koTUXQrb,uuid=feebc8fd-f8b0-4e75-abc3-e63fcdb67171 -k en-us -rtc base=localtime,clock=host,driftfix=slew  -monitor stdio -qmp tcp:0:5555,server,nowait -boot menu=on -bios /usr/share/seabios/bios.bin -drive file=/home/rhel6u4_mazhang.qcow2,if=none,id=drive-scsi-disk,format=qcow2,cache=none,werror=stop,rerror=stop -device virtio-scsi-pci,id=scsi0,addr=0x5 -device scsi-disk,drive=drive-scsi-disk,bus=scsi0.0,scsi-id=0,lun=0,id=scsi-disk,bootindex=1 -netdev tap,id=hostnet0,downscript=no -device e1000,netdev=hostnet0,id=net0,mac=00:1a:4a:2e:28:1b,bus=pci.0,addr=0x4,bootindex=2 -chardev socket,path=/tmp/isa-serial1,server,nowait,id=isa1 -device isa-serial,chardev=isa1,id=isa-serial1 -vnc :9  -drive file=/root/zhangjunyi/virtio_12G.qcow2,format=qcow2,if=none,id=ide1,cache=none,werror=stop,rerror=stop  -device ide-drive,drive=ide1,id=ide2 -device sga
2.? drive_add
drive_add [[<domain>:]<bus>:]<slot>
[file=file][,if=type][,bus=n]
[,unit=m][,media=d][,index=i]
[,cyls=c,heads=h,secs=s[,trans=t]]
[,snapshot=on|off][,cache=on|off]
[,readonly=on|off][,copy-on-read=on|off] -- add drive to PCI storage controller
  
Actual results:
(qemu) ? drive_add result do not include iops,iops_wr,iops_rd,bps,bps_wr,bps_rd inofs
drive_add [[<domain>:]<bus>:]<slot>
[file=file][,if=type][,bus=n]
[,unit=m][,media=d][,index=i]
[,cyls=c,heads=h,secs=s[,trans=t]]
[,snapshot=on|off][,cache=on|off]
[,readonly=on|off][,copy-on-read=on|off] -- add drive to PCI storage controller
Expected results:
Should includes iops,iops_wr,iops_rd,bps,bps_wr,bps_rd inofs


Additional info:
1. I tested latest upstream(qemu1.3) hit the same problem.
2. /usr/libexec/qemu-kvm --help can show iops,iops_wr,iops_rd,bps,bps_wr,bps_rd inofs
#/usr/libexec/qemu-kvm --help
.............................
-drive [file=file][,if=type][,bus=n][,unit=m][,media=d][,index=i]
       [,cyls=c,heads=h,secs=s[,trans=t]][,snapshot=on|off]
       [,cache=writethrough|writeback|none|directsync|unsafe][,format=f]
       [,serial=s][,addr=A][,id=name][,aio=threads|native]
       [,readonly=on|off][,copy-on-read=on|off]
       [[,bps=b]|[[,bps_rd=r][,bps_wr=w]]][[,iops=i]|[[,iops_rd=r][,iops_wr=w]]
                use 'file' as a drive image
3. Can hot add disk with io throttling by using drive_add and device_add
Comment 2 Eric Blake 2013-12-20 17:40:58 EST
Libvirt doesn't care about HMP help output.  We _do_ care about being able to parse the "iops" and friends fields out of the "query-blocks" QMP command (output; if the fields aren't present we cope), and also about being able to set the "iops" and friends fields in the "block_set_io_throttle" QMP command (input, but if the QMP command exists, the fields exist, since the qapi-schema.json documents the fields have always been part of the QMP command).  Thus, we don't care about parsing help output for either input or output.  Seems like you can close this bug.
Comment 3 Ademar Reis 2013-12-27 12:02:08 EST
As Eric explained in comment #2, libvirt doesn't use this output. Since we won't support direct usage of HMP/QMP in RHEL7, I'm closing it as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.