Bug 88875 - usernetctl broken for wireless interfaces
Summary: usernetctl broken for wireless interfaces
Status: CLOSED DUPLICATE of bug 88568
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-15 08:13 UTC by James Clark
Modified: 2014-03-17 02:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Clark 2003-04-15 08:13:44 UTC
If I configure a wireless interface eth1 using redhat-config-network with user
control allowed and then do ifup eth1, I get a bunch of errors ending with a
message that user control is not allowed.

The problem is that redhat-config-network is giving ifcfg-eth1 mode 600
(presumably to protect the WEP key and ESSID).  ifup is sourcing the config file
before it calls usernetctl, which obviously fails in this case; it looks like it
is doing this to avoid bug #82246.

An alternative approach to fixing bug #82246 which doesn't cause this problem is
for ifup explicitly to figure out the file in /etc/sysconfig/network-scripts
that the user-specified config file is hard-linked to, e.g. replace the call to
source_config immediately before usernetctl in ifup/ifdown by:

INODE=`ls -i ${CONFIG}  | awk '{ print $1 }'`
DEVICE=`ls -i | awk '{ if ($1 == inode) { print $2; exit } }' inode=$INODE`

Comment 1 Niels Kristian Jensen 2003-06-10 11:43:23 UTC
Isn't this a duplicate of bug# 888568 ?

Comment 2 Bill Nottingham 2003-06-10 15:13:03 UTC
Yes.

*** This bug has been marked as a duplicate of 88568 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:52:41 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.