This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 888780 - misleading error message
misleading error message
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-novaclient (Show other bugs)
2.1
Unspecified Unspecified
low Severity low
: snapshot4
: 2.1
Assigned To: Jakub Ruzicka
Yaniv Kaul
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-19 08:22 EST by Matthias Runge
Modified: 2016-04-26 09:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-27 14:47:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthias Runge 2012-12-19 08:22:06 EST
Description of problem:

[root@rhel-test ~(keystone_admin)]$ openstack-status | grep network
openstack-nova-network:       active
[root@rhel-test ~(keystone_admin)]$ nova network-list
ERROR: string indices must be integers, not str

there are no networks defined, currently.

Version-Release number of selected component (if applicable):
rpm -q openstack-nova
openstack-nova-2012.2.1-2.el6ost.noarch
rpm -q python-novaclient
python-novaclient-2.10.0-1.el6ost.noarch
Comment 2 Alan Pevec 2013-02-18 07:01:03 EST
Could not reproduce with python-novaclient-2.10.0-2.el6ost.noarch
Comment 3 Matthias Runge 2013-02-18 07:44:10 EST
seems to be fixed for me.

Note You need to log in before you can comment on or make changes to this bug.