Bug 8889 - mkbootdisk should run OK without parameters
mkbootdisk should run OK without parameters
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: mkbootdisk (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-26 04:14 EST by Johan Walles
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-26 04:14:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johan Walles 2000-01-26 04:14:39 EST
Because I yesterday had to -- over the phone -- help a thoroughly computer
impaired friend  making a boot disk for her RH61 system I have this
enhancement suggestion for mkbootdisk:

If it is run without parameters it should assume reasonable defaults, ask
the user if the defaults are OK and then make the boot disk.

Reasonable defaults could be:
device = /dev/fd0
kernel version could be the latest version found in /lib/modules or maybe
somehow located by looking in /proc/version

Otherwise, the tool works nicely.

  cheers //Johan
Comment 1 Erik Troan 2002-06-03 14:39:49 EDT
perhaps, but nobody else has ever asked for this so...

fwiw, mkbootdisk `uname -r` does what you want. You could (easily) argue that
this would be a much more sane default, but right now it mimics mkinitrd and
that default doesn't make sense for mkintird, so I'm going to leave it.

Note You need to log in before you can comment on or make changes to this bug.