This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 888936 - [gu] pofilter newlines test failed for a few msgids
[gu] pofilter newlines test failed for a few msgids
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
IDM QE LIST
: Translation
Depends On:
Blocks: 771481
  Show dependency treegraph
 
Reported: 2012-12-19 15:03 EST by John Sefler
Modified: 2013-02-21 04:05 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 04:05:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-12-19 15:03:44 EST
Description of problem:

THE TRANSLATIONS SHOWN BELOW ARE FAILING THE pofilter newlines TEST.  WHEN TRANSLATIING A msgid, THE "\n" CHARACTERS SHOULD USED ACCORDINGLY.


[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/gu/LC_MESSAGES/rhsm.mo > /usr/share/locale/gu/LC_MESSAGES/rhsm.po
[root@jsefler-6 ~]# pofilter --gnome -t newlines /usr/share/locale/gu/LC_MESSAGES/rhsm.po
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: PACKAGE VERSION\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-12-11 16:38-0500\n"
"PO-Revision-Date: 2012-12-13 11:52-0500\n"
"Last-Translator: Ankit Patel <ankit@redhat.com>\n"
"Language-Team: Gujarati\n"
"Language: gu\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=(n != 1)\n"
"X-Generator: Zanata 2.0.2\n"

# (pofilter) newlines: Different line endings
msgid ""
"Redeeming the subscription may take a few minutes.\n"
"Please provide an email address to receive notification\n"
"when the redemption is complete."
msgstr "ઉમેદવારીમાંથી મુક્ત કરવા માટે થોડો સમય લાગી શકે છે. મહેરબાની કરીને સૂચના પ્રાપ્ત કરવા માટે ઇમેઇલ સરનામાંને પૂરુ પાડો."

# (pofilter) newlines: Different line endings
msgid ""
"We have detected that you have multiple service levels on various products. Please select how you\n"
"want them assigned."
msgstr "અમે શોધી કાઢ્યુ કે જે તમારી પાસે વિવિધ પ્રોડક્ટો પર ઘણી સેવા સ્તરો છે. મહેરબાની કરીને પસંદ કરો કે તમે કેવી રીતે તેઓને સોંપી."
[###########################################] 100%



> msgstr "ઉમેદવારીમાંથી મુક્ત કરવા માટે થોડો સમય લાગી શકે છે. મહેરબાની કરીને સૂચના પ્રાપ્ત કરવા માટે ઇમેઇલ સરનામાંને પૂરુ પાડો."
                PUT A "\n" NEWLINE CHARACTER HERE ^


>  msgstr "અમે શોધી કાઢ્યુ કે જે તમારી પાસે વિવિધ પ્રોડક્ટો પર ઘણી સેવા સ્તરો છે. મહેરબાની કરીને પસંદ કરો કે તમે કેવી રીતે તેઓને સોંપી."
                              PUT A "\n" NEWLINE CHARACTER HERE ^


Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.18-1.el6.x86_64
Comment 2 Sweta Kothari 2012-12-20 01:35:54 EST
Have fixed this issue, please have a look.

Sweta
Comment 4 John Sefler 2013-01-07 15:42:11 EST
Verifying Version..
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.19-1.el6.x86_64


[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/gu/LC_MESSAGES/rhsm.mo > /usr/share/locale/gu/LC_MESSAGES/rhsm.po
[root@jsefler-6 ~]# pofilter -t newlines /usr/share/locale/gu/LC_MESSAGES/rhsm.po
processing 1 files...
[###########################################] 100%


[root@jsefler-6 ~]# grep "Redeeming the subscription" /usr/share/locale/gu/LC_MESSAGES/rhsm.po -B1 -A7
msgid ""
"Redeeming the subscription may take a few minutes.\n"
"Please provide an email address to receive notification\n"
"when the redemption is complete."
msgstr ""
"ઉમેદવારીમાંથી મુક્ત કરવા માટે થોડો સમય લાગી શકે છે.\n"
"મહેરબાની કરીને સૂચના પ્રાપ્ત કરવા માટે ઇમેઇલ સરનામાંને \n"
"પૂરુ પાડો."

[root@jsefler-6 ~]# grep "We have detected" /usr/share/locale/gu/LC_MESSAGES/rhsm.po -B1 -A5
msgid ""
"We have detected that you have multiple service levels on various products. Please select how you\n"
"want them assigned."
msgstr ""
"અમે શોધી કાઢ્યુ કે જે તમારી પાસે વિવિધ પ્રોડક્ટો પર ઘણી સેવા સ્તરો છે. મહેરબાની કરીને પસંદ કરો કે તમે કેવી રીતે\n"
"તેઓને સોંપી."

[root@jsefler-6 ~]# 

Moving to VERIFIED
Comment 6 errata-xmlrpc 2013-02-21 04:05:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.