Bug 888937 - Should install keystone.bash_completion
Should install keystone.bash_completion
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-keystoneclient (Show other bugs)
2.1
Unspecified Unspecified
medium Severity low
: snapshot4
: 2.1
Assigned To: Alan Pevec
Nir Magnezi
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-19 15:20 EST by Russell Bryant
Modified: 2016-04-26 10:04 EDT (History)
1 user (show)

See Also:
Fixed In Version: python-keystoneclient-0.2.0-2.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-21 15:03:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Russell Bryant 2012-12-19 15:20:21 EST
Description of problem:

python-keystoneclient includes support for bash completion but it is not installed.  The file tools/keystone.bash_completion should be installed to /etc/bash_completion.d/.


Version-Release number of selected component (if applicable):

python-keystoneclient-0.1.3.27-1.el6.noarch
Comment 4 Nir Magnezi 2013-03-14 07:14:33 EDT
Verified NVR: python-keystoneclient-0.2.0-3.el6ost.noarch

1. Installed Openstack Via packstack[1] on RHEL6.4 Server
2. su - <username>
3. ]$ keystone role-<TAB>
role-create  role-delete  role-get     role-list
Comment 6 errata-xmlrpc 2013-03-21 15:03:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0672.html

Note You need to log in before you can comment on or make changes to this bug.