This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 888939 - Should install nova.bash_completion
Should install nova.bash_completion
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-novaclient (Show other bugs)
2.1
Unspecified Unspecified
low Severity low
: snapshot3
: 2.1
Assigned To: Alan Pevec
Yaniv Kaul
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-19 15:24 EST by Russell Bryant
Modified: 2016-04-26 16:56 EDT (History)
4 users (show)

See Also:
Fixed In Version: python-novaclient-2.10.0-3.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-05 13:30:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
avoid dependecy on bash-completion (2.02 KB, patch)
2013-02-10 18:42 EST, Alan Pevec
no flags Details | Diff

  None (edit)
Description Russell Bryant 2012-12-19 15:24:53 EST
Description of problem:

python-novaclient includes support for bash completion.  The file tools/nova.bash_completion should be installed to /etc/bash_completion.d/.


Version-Release number of selected component (if applicable):

python-novaclient-2.10.0-1.el6ost.noarch
Comment 2 Alan Pevec 2012-12-21 15:38:51 EST
Fedora bug 872544
Comment 8 Alan Pevec 2013-02-10 18:40:47 EST
bash-completion RPM is not in RHEL (it's in EPEL) so completion files in /etc/bash_completion.d/ are not sourced automatically, so moving completion for novaclient to /etc/profile.d/
Comment 9 Alan Pevec 2013-02-10 18:42:57 EST
Created attachment 695946 [details]
avoid dependecy on bash-completion
Comment 11 Kashyap Chamarthy 2013-02-15 04:24:31 EST
VERIFIED.


Version info:
#-------------------------------------------------------#
[tuser1@interceptor ~]$ arch ; cat /etc/redhat-release ; rpm -q python-novaclient
x86_64
Red Hat Enterprise Linux Server release 6.4 (Santiago)
python-novaclient-2.10.0-4.el6ost.noarch
[tuser1@interceptor ~]$ 
#-------------------------------------------------------#

Verification info:
#-------------------------------------------------------#
[root@interceptor ~]# su - tuser1
[tuser1@interceptor ~]$
#-------------------------------------------------------#
[tuser1@interceptor ~]$ rpm -qf /etc/profile.d/nova.sh 
python-novaclient-2.10.0-4.el6ost.noarch
#-------------------------------------------------------#
[tuser1@interceptor ~]$ nova li<TAB>
list             list-extensions  live-migration   
[tuser1@interceptor ~]$ nova li
#-------------------------------------------------------#
Comment 13 errata-xmlrpc 2013-03-05 13:30:24 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0593.html

Note You need to log in before you can comment on or make changes to this bug.