Bug 888964 - [bn_IN] pofilter newlines test failed
[bn_IN] pofilter newlines test failed
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
IDM QE LIST
: Translation
Depends On:
Blocks: 771481
  Show dependency treegraph
 
Reported: 2012-12-19 17:20 EST by John Sefler
Modified: 2013-02-21 04:05 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 04:05:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-12-19 17:20:17 EST
Description of problem:

# (pofilter) newlines: Different line endings
msgid ""
"We have detected that you have multiple service levels on various products. Please select how you\n"
"want them assigned."
msgstr "বিভিন্ন উৎপাদনের জন্য একাধিক পরিসেবার স্তর আপনার ব্যবহারের জন্য উপস্থিত রয়েছে। সেগুলি কী ভাবে প্রয়োগ করা হবে তা অনুগ্রহ করে চিহ্নিত করুন।"

PLEASE INSERT A NEWLINE ("\n") CHARACTER BETWEEN THE SENTENCES IN THE MSGSTR LIKE THIS:
msgstr "বিভিন্ন উৎপাদনের জন্য একাধিক পরিসেবার স্তর আপনার ব্যবহারের জন্য উপস্থিত রয়েছে।\n"
"সেগুলি কী ভাবে প্রয়োগ করা হবে তা অনুগ্রহ করে চিহ্নিত করুন।"



Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.18-1.el6.x86_64
Comment 2 Runa Bhattacharjee 2012-12-20 01:50:10 EST
Essentially a mismatch of line breaks only at the start or end of a string would interfere with gettext validity checks. There are strings where the translations are shorter than the original english strings and translators choose to have less number of line breaks that are not at the start or end of the sentence. I have inserted a line break for this particular string for the moment, but if these line breaks are going to be important for the project, we would need some information on the context for their usage. Thanks.
Comment 3 Adrian Likins 2013-01-04 13:08:45 EST
looks to be fixed upstream, should be in 1.1.19
Comment 5 John Sefler 2013-01-07 15:33:22 EST
Verifying Version...
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.19-1.el6.x86_64


[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/bn_IN/LC_MESSAGES/rhsm.mo | grep -B1 -A5 "We have detected"
msgid ""
"We have detected that you have multiple service levels on various products. Please select how you\n"
"want them assigned."
msgstr ""
"বিভিন্ন উৎপাদনের জন্য একাধিক পরিসেবার স্তর আপনার ব্যবহারের জন্য উপস্থিত রয়েছে। সেগুলি কী ভাবে \n"
"প্রয়োগ করা হবে তা অনুগ্রহ করে চিহ্নিত করুন।"

[root@jsefler-6 ~]# 

Moving to VERIFIED
Comment 7 errata-xmlrpc 2013-02-21 04:05:42 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.