This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 888971 - [pt_BR] pofilter newlines test failed
[pt_BR] pofilter newlines test failed
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
IDM QE LIST
: Translation
Depends On:
Blocks: 771481 895654
  Show dependency treegraph
 
Reported: 2012-12-19 17:41 EST by John Sefler
Modified: 2013-02-21 04:05 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 04:05:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-12-19 17:41:45 EST
Description of problem:

# (pofilter) newlines: Different line endings
msgid ""
"We have detected that you have multiple service levels on various products. Please select how you\n"
"want them assigned."
msgstr "Detectamos que você possui níveis de serviço múltiplos em diversos produtos. Por favor selecione como você deseja que sejam atribuidos."

PLEASE INSERT A "\n" CHARACTER BEWTEEN THE SENTENCES LINE THIS:
msgstr "Detectamos que você possui níveis de serviço múltiplos em diversos produtos.\nPor favor selecione como você deseja que sejam atribuidos."


Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.18-1.el6.x86_64
Comment 2 Glaucia Cintra 2013-01-06 23:03:28 EST
Ḿessage above updated with caractere requested. pt-BR
Comment 5 John Sefler 2013-01-07 15:10:39 EST
Testing Version...
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.19-1.el6.x86_64

[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.mo | grep -A3 -B1 "We have detected"
msgid ""
"We have detected that you have multiple service levels on various products. Please select how you\n"
"want them assigned."
msgstr "Detectamos que você possui níveis de serviço múltiplos em diversos produtos. \\nPor favor selecione como você deseja que sejam atribuidos."



FAILED: Expected:
msgstr "Detectamos que você possui níveis de serviço múltiplos em diversos produtos. \nPor favor selecione como você deseja que sejam atribuidos."

the newline character is ONE backslash n (\n); NOT TWO backslashes n (\\n)
Comment 6 Adrian Likins 2013-01-07 16:15:28 EST
Fixed upstream in zanata. Should be in 1.1.20
Comment 9 John Sefler 2013-01-08 16:39:21 EST
Testing Version...
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.20-1.el6.x86_64


[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.mo | grep -A3 -B1 "We have detected"
msgid ""
"We have detected that you have multiple service levels on various products. Please select how you\n"
"want them assigned."
msgstr "Detectamos que você possui níveis de serviço múltiplos em diversos produtos. \\nPor favor selecione como você deseja que sejam atribuidos."

[root@jsefler-6 ~]# msgunfmt /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.mo | grep -A6 -B1 "We have detected"
msgid ""
"We have detected that you have multiple service levels on various products. "
"Please select how you\n"
"want them assigned."
msgstr ""
"Detectamos que você possui níveis de serviço múltiplos em diversos produtos. "
"\\nPor favor selecione como você deseja que sejam atribuidos."

[root@jsefler-6 ~]# 
FAILED_QA AGAIN - SAME AS COMMENT 5 - CHANGE "\\n" TO "\n" IN THE MSGSTR
Comment 11 John Sefler 2013-01-09 17:19:25 EST
Verifying Version...
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.21-1.el6.x86_64


[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.mo | grep -A5 -B1 "We have detected"
msgid ""
"We have detected that you have multiple service levels on various products. Please select how you\n"
"want them assigned."
msgstr ""
"Detectamos que você possui níveis de serviço múltiplos em diversos produtos.\n"
"Por favor selecione como você deseja que sejam atribuidos."

VERIFIED



[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.mo > /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.po
[root@jsefler-6 ~]# pofilter -t newlines /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.po
processing 1 files...
[###########################################] 100%
[root@jsefler-6 ~]# 

VERIFIED: pofilter newlines test is now passing for pt_BR
Comment 13 errata-xmlrpc 2013-02-21 04:05:47 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.