Bug 888983 - [RFE] ssh keys generated by horizon have no passphrase
[RFE] ssh keys generated by horizon have no passphrase
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
2.1
Unspecified Unspecified
low Severity low
: beta
: 3.0
Assigned To: RHOS Maint
Yaniv Kaul
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-19 18:27 EST by Graeme Gillies
Modified: 2016-04-26 10:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-30 12:12:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Graeme Gillies 2012-12-19 18:27:15 EST
Hi,

It's been pointed out to us by multiple users that when a user generates a new ssh keypair in horizon, there is no passphrase on that keypair, which is unsecure.

Ideally it would prompt for a passphrase for the keypair before generating, and generate the keypair with that passphrase.

Regards,

Graeme
Comment 3 Perry Myers 2012-12-20 11:34:43 EST
Nova and Horizon supports uploading of keys created outside of OpenStack, so this functionality is available via that mechanism.

However, if we think that it's specifically needed to have support for key generation w/ passphrase inside of OpenStack, this would be an RFE on both Nova and Horizon.

In any case it is an RFE so moving to FutureFeature and next release for further investigation
Comment 4 Russell Bryant 2013-04-30 12:12:38 EDT
I'm going to close this as "won't fix".  The support in nova is intended to be basic and for convenience.  There is also the ability to upload keys that you create yourself.  I think if you want anything more than the basic support, you should generate and upload your own key.

Note You need to log in before you can comment on or make changes to this bug.