Bug 88901 - cpio verbose output is at error level 2
cpio verbose output is at error level 2
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: cpio (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-15 10:15 EDT by paulm
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-21 07:54:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description paulm 2003-04-15 10:15:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.0.3705)

Description of problem:
I expected the verbose output of cpio to be level 1 output, actually it is 
level 2. This makes it difficult to distinguish/process errors using normal 
verbose output.




Version-Release number of selected component (if applicable):
cpio-2.5-3

How reproducible:
Always

Steps to Reproduce:
1. find /home | cpio -ovB -O home.cpio > home.cpio.log
2. vi home.cpio.log , it is empty!
3. find /home | cpop -ovB -O home.cpio 2> home.cpio.log
4. vi home.cpio.log, it has the cpio verbose output.
5. Interestingly, if I run "cpio -ivt -I home.cpio > verify.log"
   the verify.log will contain cpio output. 
        

Actual Results:  If the "t" parameter is not used the verbose output goes to 
level 2
If the "t" parameter is used the verbose output goes to level 1.

Expected Results:  I expected cpio verbose output to be level 1 output in all 
cases, and cpio errors to be level 2 output.


Additional info:

I tried with the default 7.3 cpio version, then updated to cpio-2.5-3 and had 
same result.
Comment 1 Peter Vrabec 2004-12-21 07:54:22 EST
cpio writes the archive onto the standard output. 
find /home | cpio -ovB > home.cpio > home.cpio.log

I think that's the reason it can't use stdout as verbose output. 

Note You need to log in before you can comment on or make changes to this bug.