Bug 889235 - ami-cfd35fa6 RHEL 5.9 i386 us-east-1
Summary: ami-cfd35fa6 RHEL 5.9 i386 us-east-1
Keywords:
Status: CLOSED DUPLICATE of bug 889514
Alias: None
Product: Cloud Image Validation
Classification: Red Hat
Component: images
Version: RHEL5.9
Hardware: i386
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: mkovacik
QA Contact: mkovacik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-20 15:11 UTC by mkovacik
Modified: 2012-12-21 14:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-21 14:56:47 UTC
Target Upstream Version:


Attachments (Terms of Use)
ami-cfd35fa6.yaml (42.87 KB, text/yaml)
2012-12-20 15:11 UTC, mkovacik
no flags Details

Description mkovacik 2012-12-20 15:11:04 UTC

Comment 1 mkovacik 2012-12-20 15:11:19 UTC
Created attachment 666714 [details]
ami-cfd35fa6.yaml

Comment 2 mkovacik 2012-12-20 15:11:24 UTC
Validation failed for ami-cfd35fa6 in us-east-1 product: RHEL, version: 5.9, arch: i386

m1.small
stage1:
test testcase_01_ipv6 succeeded
test testcase_02_bash_history succeeded
test testcase_03_chkconfig succeeded
test testcase_04_cloud_firstboot succeeded
test testcase_05_grub succeeded
test testcase_06_inittab succeeded
test testcase_07_libc6_xen_conf succeeded
test testcase_08_memory succeeded
test testcase_09_nameserver succeeded
test testcase_10_networking succeeded
test testcase_12_passwd_group succeeded
test testcase_13_resize2fs succeeded
test testcase_14_host_details succeeded
test testcase_15_rhel_version succeeded
test testcase_16_selinux succeeded
test testcase_17_shells succeeded
test testcase_18_sshd succeeded
test testcase_19_rhn_system_id succeeded
test testcase_20_auditd succeeded
test testcase_21_disk_size_format succeeded
test testcase_22_gpg_keys succeeded
test testcase_23_syslog succeeded
test testcase_24_yum_plugin succeeded
test testcase_26_verify_rpms succeeded
test testcase_27_yum_repos failed
--->
	command: yum repolist -v all | csplit --prefix=repolist_xx - '%pkgsack time:%1'
	result: passed
<---
--->
	actual repos: {'rhui-us-east-1-rhel-server-releases-beta': {'repo-status': 'enabled'}, 'rhui-us-east-1-rhel-server-releases-debug-beta': {'repo-status': 'enabled'}, 'rhui-us-east-1-client-config-server-5': {'repo-status': 'enabled'}, 'rhel-debuginfo': {'repo-status': 'disabled'}, 'rhui-us-east-1-rhel-server-source': {'repo-status': 'disabled'}, 'rhui-us-east-1-client-config-server-5-beta': {'repo-status': 'enabled'}, 'rhui-us-east-1-rhel-server': {'repo-status': 'enabled'}, 'rhui-us-east-1-rhel-server-releases-source-beta': {'repo-status': 'disabled'}}
	expected repos: {'rhui-us-east-1-rhel-server-releases': {'repo-status': 'enabled'}, 'rhui-us-east-1-rhel-server-releases-optional': {'repo-status': 'enabled'}, 'rhui-us-east-1-rhel-server-releases-optional-source': {'repo-status': 'disabled'}, 'rhel-source': {'repo-status': 'disabled'}, 'rhui-us-east-1-client-config-server-5': {'repo-status': 'enabled'}}
	result: failed
<---
test testcase_28_iptables succeeded
test testcase_29_swap_file succeeded
test testcase_30_rhn_certificates succeeded
test testcase_31_subscription_management failed
--->
	command: yum --disablerepo="*" repolist | grep -i subscription-manager
	result: passed
<---
--->
	actual: yum --enableplugin=subscription-manager --disablerepo="*" 
 repolist
Loaded plugins: amazon-id, fastestmirror, product-id, rhui-lb, security,
              : subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Loading mirror speeds from cached hostfile
repolist: 0
[root@ip-10-3-94-5 ~]# 
	command: yum --enableplugin=subscription-manager --disablerepo="*" repolist
	expectation: Loaded plugins:[^
]*subscription-manager
	result: failed
<---
--->
	actual: subscription-manager list

	command: subscription-manager list
	expectation: Status:\s*Not.Subscribed
	result: failed
<---
test testcase_50_yum_package_install succeeded
test testcase_55_yum_group_install succeeded
test testcase_60_yum_update succeeded
test testcase_99_reboot succeeded
stage2:
test testcase_08_memory succeeded
test testcase_25_uname succeeded
c1.medium
stage1:
test testcase_01_ipv6 succeeded
test testcase_02_bash_history succeeded
test testcase_03_chkconfig succeeded
test testcase_04_cloud_firstboot succeeded
test testcase_05_grub succeeded
test testcase_06_inittab succeeded
test testcase_07_libc6_xen_conf succeeded
test testcase_08_memory succeeded
test testcase_09_nameserver succeeded
test testcase_10_networking succeeded
test testcase_12_passwd_group succeeded
test testcase_13_resize2fs succeeded
test testcase_14_host_details succeeded
test testcase_15_rhel_version succeeded
test testcase_16_selinux succeeded
test testcase_17_shells succeeded
test testcase_18_sshd succeeded
test testcase_19_rhn_system_id succeeded
test testcase_20_auditd succeeded
test testcase_21_disk_size_format succeeded
test testcase_22_gpg_keys succeeded
test testcase_23_syslog succeeded
test testcase_24_yum_plugin succeeded
test testcase_26_verify_rpms succeeded
test testcase_27_yum_repos failed
--->
	command: yum repolist -v all | csplit --prefix=repolist_xx - '%pkgsack time:%1'
	result: passed
<---
--->
	actual repos: {'rhui-us-east-1-rhel-server-releases-beta': {'repo-status': 'enabled'}, 'rhui-us-east-1-rhel-server-releases-debug-beta': {'repo-status': 'enabled'}, 'rhui-us-east-1-client-config-server-5': {'repo-status': 'enabled'}, 'rhel-debuginfo': {'repo-status': 'disabled'}, 'rhui-us-east-1-rhel-server-source': {'repo-status': 'disabled'}, 'rhui-us-east-1-client-config-server-5-beta': {'repo-status': 'enabled'}, 'rhui-us-east-1-rhel-server': {'repo-status': 'enabled'}, 'rhui-us-east-1-rhel-server-releases-source-beta': {'repo-status': 'disabled'}}
	expected repos: {'rhui-us-east-1-rhel-server-releases': {'repo-status': 'enabled'}, 'rhui-us-east-1-rhel-server-releases-optional': {'repo-status': 'enabled'}, 'rhui-us-east-1-rhel-server-releases-optional-source': {'repo-status': 'disabled'}, 'rhel-source': {'repo-status': 'disabled'}, 'rhui-us-east-1-client-config-server-5': {'repo-status': 'enabled'}}
	result: failed
<---
test testcase_28_iptables succeeded
test testcase_29_swap_file succeeded
test testcase_30_rhn_certificates succeeded
test testcase_31_subscription_management failed
--->
	command: yum --disablerepo="*" repolist | grep -i subscription-manager
	result: passed
<---
--->
	actual: yum --enableplugin=subscription-manager --disablerepo="* 
" repolist
Loaded plugins: amazon-id, fastestmirror, product-id, rhui-lb, security,
              : subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Loading mirror speeds from cached hostfile
repolist: 0
[root@ip-10-3-94-26 ~]# 
	command: yum --enableplugin=subscription-manager --disablerepo="*" repolist
	expectation: Loaded plugins:[^
]*subscription-manager
	result: failed
<---
--->
	actual: subscription-manager list

	command: subscription-manager list
	expectation: Status:\s*Not.Subscribed
	result: failed
<---
test testcase_50_yum_package_install succeeded
test testcase_55_yum_group_install succeeded
test testcase_60_yum_update succeeded
test testcase_99_reboot succeeded
stage2:
test testcase_08_memory succeeded
test testcase_25_uname succeeded
t1.micro
stage1:
test testcase_01_ipv6 succeeded
test testcase_02_bash_history succeeded
test testcase_03_chkconfig succeeded
test testcase_04_cloud_firstboot succeeded
test testcase_05_grub succeeded
test testcase_06_inittab succeeded
test testcase_07_libc6_xen_conf succeeded
test testcase_08_memory succeeded
test testcase_09_nameserver succeeded
test testcase_10_networking succeeded
test testcase_12_passwd_group succeeded
test testcase_13_resize2fs succeeded
test testcase_14_host_details succeeded
test testcase_15_rhel_version succeeded
test testcase_16_selinux succeeded
test testcase_17_shells succeeded
test testcase_18_sshd succeeded
test testcase_19_rhn_system_id succeeded
test testcase_20_auditd succeeded
test testcase_21_disk_size_format succeeded
test testcase_22_gpg_keys succeeded
test testcase_23_syslog succeeded
test testcase_24_yum_plugin succeeded
test testcase_26_verify_rpms succeeded
test testcase_27_yum_repos failed
--->
	command: yum repolist -v all | csplit --prefix=repolist_xx - '%pkgsack time:%1'
	result: passed
<---
--->
	actual repos: {'rhui-us-east-1-rhel-server-releases-beta': {'repo-status': 'enabled'}, 'rhui-us-east-1-rhel-server-releases-debug-beta': {'repo-status': 'enabled'}, 'rhui-us-east-1-client-config-server-5': {'repo-status': 'enabled'}, 'rhel-debuginfo': {'repo-status': 'disabled'}, 'rhui-us-east-1-rhel-server-source': {'repo-status': 'disabled'}, 'rhui-us-east-1-client-config-server-5-beta': {'repo-status': 'enabled'}, 'rhui-us-east-1-rhel-server': {'repo-status': 'enabled'}, 'rhui-us-east-1-rhel-server-releases-source-beta': {'repo-status': 'disabled'}}
	expected repos: {'rhui-us-east-1-rhel-server-releases': {'repo-status': 'enabled'}, 'rhui-us-east-1-rhel-server-releases-optional': {'repo-status': 'enabled'}, 'rhui-us-east-1-rhel-server-releases-optional-source': {'repo-status': 'disabled'}, 'rhel-source': {'repo-status': 'disabled'}, 'rhui-us-east-1-client-config-server-5': {'repo-status': 'enabled'}}
	result: failed
<---
test testcase_28_iptables succeeded
test testcase_29_swap_file succeeded
test testcase_30_rhn_certificates succeeded
test testcase_31_subscription_management failed
--->
	command: yum --disablerepo="*" repolist | grep -i subscription-manager
	result: passed
<---
--->
	actual: yum --enableplugin=subscription-manager --disablerepo="* 
" repolist
Loaded plugins: amazon-id, fastestmirror, product-id, rhui-lb, security,
              : subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Loading mirror speeds from cached hostfile
repolist: 0
[root@ip-10-3-94-24 ~]# 
	command: yum --enableplugin=subscription-manager --disablerepo="*" repolist
	expectation: Loaded plugins:[^
]*subscription-manager
	result: failed
<---
--->
	actual: subscription-manager list

	command: subscription-manager list
	expectation: Status:\s*Not.Subscribed
	result: failed
<---
test testcase_50_yum_package_install succeeded
test testcase_55_yum_group_install succeeded
test testcase_60_yum_update succeeded
test testcase_99_reboot succeeded
stage2:
test testcase_08_memory succeeded
test testcase_25_uname succeeded

Comment 3 mkovacik 2012-12-20 15:34:41 UTC
Issues:
 - rh-amazon-rhui-client-beta installed: Image Failure
 - subscription manager testcases: testcase error: subscription manager is correctly disabled

Comment 4 mkovacik 2012-12-21 14:56:47 UTC

*** This bug has been marked as a duplicate of bug 889514 ***


Note You need to log in before you can comment on or make changes to this bug.