Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 889252 - gnome-keyring-ask gets stuck upon login
Summary: gnome-keyring-ask gets stuck upon login
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-keyring
Version: 6.4
Hardware: Unspecified
OS: Linux
medium
high
Target Milestone: rc
: ---
Assignee: Zeeshan Ali
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1075802 1172231 1269194
TreeView+ depends on / blocked
 
Reported: 2012-12-20 15:46 UTC by Jiri Koten
Modified: 2018-12-04 14:55 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-03 15:05:01 UTC
Target Upstream Version:


Attachments (Terms of Use)
/var/log/messages (3.19 MB, text/plain)
2012-12-20 15:50 UTC, Jiri Koten
no flags Details
backtrace (14.80 KB, text/plain)
2012-12-20 15:51 UTC, Jiri Koten
no flags Details

Description Jiri Koten 2012-12-20 15:46:34 UTC
Description of problem:
I have different password for login keyring from user password. Therefor upon login gnome-keyring asks for this password to unlock the keyring. 

Sometimes gnome-keyring-ask gets stuck, no gtk dialog with password prompt opens and as a result nm-applet won't appear in panel and also pidgin gets stuck.

I have saved session, so several apps like pidgin and gnome terminal are auto started upon login.  

Sending SIGUSR1 to the stuck gnome-keyring-ask process wakes it up and password prompt is displayed which also wakes up pidgin. nm-applet is still not displayed in the panel.

Version-Release number of selected component (if applicable):
gnome-keyring-2.28.2-8.el6_3

How reproducible:
random, no exact reproducer, but hit it several times.

Comment 1 Jiri Koten 2012-12-20 15:50:17 UTC
Created attachment 666748 [details]
/var/log/messages

[snip]
...
gnome-keyring-daemon[5333]: Couldn't unlock login keyring with provided password
gnome-keyring-daemon[5333]: Failed to unlock login on startup
gnome-session[5342]: EggSMClient-WARNING: Desktop file '/etc/xdg/autostart/esc.desktop' has malformed Icon key 'esc.png'(should not include extension)
kernel: fuse init (API version 7.13)
seahorse-daemon[5400]: DNS-SD initialization failed: Daemon not running
seahorse-daemon[5400]: init gpgme version 1.1.8
...
gnome-keyring-daemon[5333]: missing dialog response from ask tool
gnome-keyring-ask: could not grab keyboard: 3
gnome-keyring-ask: could not grab keyboard: 3
gnome-keyring-daemon[5333]: couldn't write 8 bytes to client: Broken pipe
gnome-keyring-daemon[5333]: couldn't write 8 bytes to client: Broken pipe

Comment 2 Jiri Koten 2012-12-20 15:51:21 UTC
Created attachment 666749 [details]
backtrace

Backtrace of stuck gnome-keyring-ask process.

Comment 3 RHEL Program Management 2013-10-14 00:07:50 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.


Note You need to log in before you can comment on or make changes to this bug.