Bug 889881 - user can't change admin status of a port / network
user can't change admin status of a port / network
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
unspecified Severity medium
: snapshot1
: 3.0
Assigned To: Julie Pichon
Ofer Blaut
https://blueprints.launchpad.net/hori...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-23 14:30 EST by Ofer Blaut
Modified: 2016-04-26 13:32 EDT (History)
5 users (show)

See Also:
Fixed In Version: python-django-horizon-2013.1.1-1.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-29 11:03:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ofer Blaut 2012-12-23 14:30:49 EST
Description of problem:

user can't change admin status of a port / network via horizon
  

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. create a network ( it will be up ) - you cant disable it
2. create a subnet and a port will be up - you can't change it 
3.
  
Actual results:


Expected results:

user should be able to change admin status of a port / network via horizon

Additional info:
Comment 2 Yaniv Kaul 2012-12-23 14:39:58 EST
Need to verify this is a Horizon bug and not Nova - please test via CLI.
Comment 3 Gary Kotton 2012-12-26 06:29:52 EST
Yes, this is a bug.
At them moment this support is lacking in horizon.
Comment 4 Ofer Blaut 2012-12-26 06:48:54 EST
Quantum CLI supports 

quantum port-update <port-id> --admin_state_up false 
quantum network-update <network-id> --admin_state_up false 

Horizon doesn't
Comment 5 Julie Pichon 2013-01-15 12:34:30 EST
Quantum support in Horizon Folsom is quite basic, this is being improved upstream as part of a series of blueprints for the next release (grizzly). 

In this case: https://blueprints.launchpad.net/horizon/+spec/improve-quantum-summary-table
Comment 6 Ofer Blaut 2013-01-27 03:12:46 EST
Ok, so the bug  should be posted and mark by PM
Comment 8 Ofer Blaut 2013-05-28 04:39:06 EDT
tested 

i have changed port admin status and check both in CLI and GUI the port status
ALso tested i can set network to admin status false


python-django-horizon-2013.1.1-2.el6ost.noarch
Comment 10 errata-xmlrpc 2013-05-29 11:03:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0878.html

Note You need to log in before you can comment on or make changes to this bug.