Bug 88990 - up2date error connecting to rhn
up2date error connecting to rhn
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-16 00:44 EDT by harry paul
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-21 10:41:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description harry paul 2003-04-16 00:44:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
up2date was connecting correctly and then just quit.  I've been running through
a win2k Direcway 2-way server to a local hub and then to my RH8.0 box.  It has
worked correctly for several months and all of a sudden I get errors.  This is
the error reported by SSL

************************
Exception type SSL.Error

Exception Handler Information
Traceback (most recent call last):
  File "/usr/bin/../share/rhn/rhn_applet/rhn_applet.py", line 424, in refresh
    self.model.refresh(force)
  File "/usr/bin/../share/rhn/rhn_applet/rhn_applet_model.py", line 264, in refresh
    self.__rpc_server__.refresh(force)
  File "/usr/bin/../share/rhn/rhn_applet/rhn_applet_rpc.py", line 84, in refresh
    status = server.applet.poll_status()
  File "/usr/src/build/143041-i386/install/usr/lib/python2.2/xmlrpclib.py", line
821, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python2.2/site-packages/rhn/rpclib.py", line 126, in _request
    verbose=self._verbose
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 118, in request
    headers, fd = req.send_http(host, handler)
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 602, in send_http
    headers=self.headers)
  File "/usr/src/build/143041-i386/install/usr/lib/python2.2/httplib.py", line
537, in request
    self._send_request(method, url, body, headers)
  File "/usr/src/build/143041-i386/install/usr/lib/python2.2/httplib.py", line
553, in _send_request
    self.putrequest(method, url)
  File "/usr/src/build/143041-i386/install/usr/lib/python2.2/httplib.py", line
453, in putrequest
    self.send(str)
  File "/usr/src/build/143041-i386/install/usr/lib/python2.2/httplib.py", line
407, in send
    self.sock.sendall(str)
  File "/usr/lib/python2.2/site-packages/rhn/SSL.py", line 185, in write
    sent = self._connection.send(data)
Error: [('SSL routines', 'SSL23_WRITE', 'ssl handshake failure')]

Need more info??
thanks,
Harry


Version-Release number of selected component (if applicable):
up2date-3.0.7-1

How reproducible:
Always

Steps to Reproduce:
1.try to connect to rhn using up2date
2.
3.
    

Actual Results:  get the error message above.

Expected Results:  Should have gotten the connection to rhn. 

Additional info:
Comment 1 harry paul 2003-04-21 01:09:52 EDT
Well, whatever you did worked fine.  This hasn't been working for several weeks
and just a day or two after putting this bug in the system, it starts working again.

thanks guys,

Harry
Comment 2 Josef Komenda 2003-04-21 10:41:47 EDT
Since we haven't changed anything, I'll use the vague and unhelpful excuse that
it might have been a problem with the user's ISP. 

Note You need to log in before you can comment on or make changes to this bug.