Bug 890025 - [abrt] BigPtrArray::Index2Block (rtf or docx import)
[abrt] BigPtrArray::Index2Block (rtf or docx import)
Status: CLOSED DUPLICATE of bug 863810
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:52824d6ce33bf922fc4a589cce0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-24 07:12 EST by Yasser Rabi
Modified: 2013-01-04 14:09 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-04 14:09:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: core_backtrace (8.38 KB, text/plain)
2012-12-24 07:12 EST, Yasser Rabi
no flags Details
File: environ (2.64 KB, text/plain)
2012-12-24 07:12 EST, Yasser Rabi
no flags Details
File: limits (1.29 KB, text/plain)
2012-12-24 07:12 EST, Yasser Rabi
no flags Details
File: backtrace (2.67 MB, text/plain)
2012-12-24 07:13 EST, Yasser Rabi
no flags Details
File: cgroup (129 bytes, text/plain)
2012-12-24 07:13 EST, Yasser Rabi
no flags Details
File: smolt_data (2.54 KB, text/plain)
2012-12-24 07:13 EST, Yasser Rabi
no flags Details
File: executable (42 bytes, text/plain)
2012-12-24 07:13 EST, Yasser Rabi
no flags Details
File: maps (91.89 KB, text/plain)
2012-12-24 07:13 EST, Yasser Rabi
no flags Details
File: dso_list (20.88 KB, text/plain)
2012-12-24 07:13 EST, Yasser Rabi
no flags Details
File: proc_pid_status (939 bytes, text/plain)
2012-12-24 07:13 EST, Yasser Rabi
no flags Details
File: var_log_messages (350 bytes, text/plain)
2012-12-24 07:13 EST, Yasser Rabi
no flags Details
File: open_fds (2.38 KB, text/plain)
2012-12-24 07:13 EST, Yasser Rabi
no flags Details

  None (edit)
Description Yasser Rabi 2012-12-24 07:12:20 EST
Version-Release number of selected component:
libreoffice-core-3.5.7.2-6.fc17

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --writer file:///home/yasser/T%C3%A9l%C3%A9chargements/reporttemplate.doc --splash-pipe=6
crash_function: BigPtrArray::Index2Block
kernel:         3.6.8-2.fc17.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #0 BigPtrArray::Index2Block at /usr/src/debug/libreoffice-3.5.7.2/sw/source/core/bastyp/bparr.cxx:195
: #1 BigPtrArray::operator[] at /usr/src/debug/libreoffice-3.5.7.2/sw/source/core/bastyp/bparr.cxx:143
: #2 operator[] at /usr/src/debug/libreoffice-3.5.7.2/sw/inc/ndarr.hxx:145
: #3 operator++ at /usr/src/debug/libreoffice-3.5.7.2/sw/inc/ndindex.hxx:191
: #4 SwNodes::ExpandRangeForTableBox at /usr/src/debug/libreoffice-3.5.7.2/sw/source/core/docnode/ndtbl.cxx:1253
: #5 SwXText::Impl::ConvertCell at /usr/src/debug/libreoffice-3.5.7.2/sw/source/core/unocore/unotext.cxx:1839
: #6 SwXText::convertToTable at /usr/src/debug/libreoffice-3.5.7.2/sw/source/core/unocore/unotext.cxx:2218
: #7 writerfilter::dmapper::DomainMapperTableHandler::endTable at /usr/src/debug/libreoffice-3.5.7.2/writerfilter/source/dmapper/DomainMapperTableHandler.cxx:716
: #8 writerfilter::TableManager<com::sun::star::uno::Reference<com::sun::star::text::XTextRange>, boost::shared_ptr<writerfilter::dmapper::TablePropertyMap> >::resolveCurrentTable at /usr/src/debug/libreoffice-3.5.7.2/writerfilter/inc/resourcemodel/TableManager.hxx:1003
: #9 writerfilter::TableManager<com::sun::star::uno::Reference<com::sun::star::text::XTextRange>, boost::shared_ptr<writerfilter::dmapper::TablePropertyMap> >::endLevel at /usr/src/debug/libreoffice-3.5.7.2/writerfilter/inc/resourcemodel/TableManager.hxx:729

Potential duplicate bug: 758860
Comment 1 Yasser Rabi 2012-12-24 07:12:25 EST
Created attachment 668467 [details]
File: core_backtrace
Comment 2 Yasser Rabi 2012-12-24 07:12:27 EST
Created attachment 668468 [details]
File: environ
Comment 3 Yasser Rabi 2012-12-24 07:12:33 EST
Created attachment 668469 [details]
File: limits
Comment 4 Yasser Rabi 2012-12-24 07:13:14 EST
Created attachment 668470 [details]
File: backtrace
Comment 5 Yasser Rabi 2012-12-24 07:13:17 EST
Created attachment 668471 [details]
File: cgroup
Comment 6 Yasser Rabi 2012-12-24 07:13:19 EST
Created attachment 668472 [details]
File: smolt_data
Comment 7 Yasser Rabi 2012-12-24 07:13:22 EST
Created attachment 668473 [details]
File: executable
Comment 8 Yasser Rabi 2012-12-24 07:13:26 EST
Created attachment 668474 [details]
File: maps
Comment 9 Yasser Rabi 2012-12-24 07:13:29 EST
Created attachment 668475 [details]
File: dso_list
Comment 10 Yasser Rabi 2012-12-24 07:13:32 EST
Created attachment 668476 [details]
File: proc_pid_status
Comment 11 Yasser Rabi 2012-12-24 07:13:34 EST
Created attachment 668477 [details]
File: var_log_messages
Comment 12 Yasser Rabi 2012-12-24 07:13:37 EST
Created attachment 668478 [details]
File: open_fds
Comment 13 David Tardon 2012-12-25 08:00:32 EST
Could you attach the file here?
Comment 14 Michael Stahl 2013-01-04 14:09:40 EST
haven't i seen this stack before... ah yes, duplicate

*** This bug has been marked as a duplicate of bug 863810 ***

Note You need to log in before you can comment on or make changes to this bug.