Bug 890028 - Philips PCVC675K webcam broken
Summary: Philips PCVC675K webcam broken
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 17
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-24 12:34 UTC by Gert Vervoort
Modified: 2012-12-25 13:55 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-25 13:55:47 UTC


Attachments (Terms of Use)
Picture taken with cheese (181.11 KB, image/jpeg)
2012-12-24 12:34 UTC, Gert Vervoort
no flags Details

Description Gert Vervoort 2012-12-24 12:34:53 UTC
Created attachment 668480 [details]
Picture taken with cheese

Description of problem:

The pwc driver for the Philips PCVC675K USB webcam gives an "recv_control_msg error -32 req 04 val 1700" kernel error message when being loaded:

And then when trying to use the webcam with the Cheese application, the video is garbage (see attached picture).


Version-Release number of selected component (if applicable):

kernel.x86_64                      3.6.10-2.fc17


How reproducible:

Always

Steps to Reproduce:
1. Attach the webcam to the USB
2. Check the kernel message and see the "recv_control_msg error -32 req 04 val 1700" error
3. start cheese
4. Check the resulting picture
  
Actual results:

[gert@jupiter tmp]$ dmesg| grep -i pwc
[   15.365755] pwc: Philips PCVC675K (Vesta) USB webcam detected.
[   15.829852] pwc: recv_control_msg error -32 req 04 val 1700
[   15.968912] pwc: Registered as video0.
[   15.968953] input: PWC snapshot button as /devices/pci0000:00/0000:00:1d.2/usb8/8-1/input/input13
[gert@jupiter tmp]$ 

See attached picture.

Expected results:

No error message in the kernel log and a decent picture

Additional info:

Comment 1 Gert Vervoort 2012-12-25 13:55:47 UTC
Just tried the webcam on my old PC (using an old Fedora version) and there also the picture is garbage. So, it looks like the webcam hardware is broken.

The kernel error message does not occur there, that seems to be an unrelated driver problem/feature. However since my HW appears to be broken, I can test if this is a problem or not.


Note You need to log in before you can comment on or make changes to this bug.