Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 890073 - Qt-only applications not themed properly
Summary: Qt-only applications not themed properly
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: qt
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-24 23:53 UTC by Francesco Frassinelli (frafra)
Modified: 2012-12-25 18:57 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-25 17:51:15 UTC
Type: Bug


Attachments (Terms of Use)

Description Francesco Frassinelli (frafra) 2012-12-24 23:53:50 UTC
Description of problem:
GTK apps are not rendered well, like there are not KDE integration.

Version-Release number of selected component (if applicable):
kcm-gtk-0.5.3-11.fc18.x86_64 

How reproducible:
Use a gtk app on Fedora 18 KDE

Steps to Reproduce:
1. Play with kcm-gtk
2. Launch a gtk app (like liveusb-creator or libreoffice)
  
Actual results:
No theme integration

Expected results:
Nice theme integrationn with oxygen

Additional info:
I use Fedora x86_64 KDE with http://apt.kde-redhat.org/apt/kde-redhat/fedora/mirrors-unstable enabled.
With Firefox I've no integration problem.

Comment 1 Rex Dieter 2012-12-25 00:42:54 UTC
rpm -q oxygen-gtk oxygen-gtk2 oxygen-gtk3

please.

and, what does

systemsettings->application appearance->gtk+ appearance
say for widget theme?  something *not* oxygen-gtk ?

Comment 2 Rex Dieter 2012-12-25 00:47:00 UTC
wrt, libreoffice in particular, you can get native kde widgets by installing:
libreoffice-kde

Comment 3 Francesco Frassinelli (frafra) 2012-12-25 11:11:02 UTC
$ rpm -q oxygen-gtk oxygen-gtk2 oxygen-gtk3 lodevbasis4.0-kde-integration
oxygen-gtk-1.2.0-3.fc18.noarch
oxygen-gtk2-1.3.1-1.fc18.x86_64
oxygen-gtk3-1.1.1-2.fc18.x86_64
lodevbasis4.0-kde-integration-4.0.0.0.beta2-12.x86_64

kde-integration for LibreOffice is installed: the problem is only theme related (the icons are taken by oxygen correctly).

Widget style: oxygen-gtk. There's Raleigh as option, but nothing changes.

Comment 4 Kevin Kofler 2012-12-25 12:16:17 UTC
I see you're using non-Fedora prerelease packages of LibreOffice, are those bundling their own GTK+? But if you use the KDE integration, you aren't using GTK+ anyway, or at least shouldn't. It uses Qt functions instead.

As for liveusb-creator, that's not a GTK+ app at all, it's a PyQt4 app.

I think your issue is really with Qt-only apps, not with GTK+ apps.

Comment 5 Francesco Frassinelli (frafra) 2012-12-25 14:39:36 UTC
Sorry, you're right: system-config-users uses gtk and it works well.

I don't think that LibreOffice 4 beta 2 uses its own GTK, because I don't get any output from: find /opt/lodev4.0/ -iname "*gtk*.so".

Comment 6 Kevin Kofler 2012-12-25 15:09:17 UTC
Try running qtconfig-qt4 (from the qt-config subpackage, install it if needed) and setting the theme to Oxygen there.

Comment 7 Francesco Frassinelli (frafra) 2012-12-25 15:15:14 UTC
Nothing changes: I tried to run is as user and as root, using Oxygen theme and the default one, saving every time.

LibreOffice 3.6.3 from F18 works correctly.

Comment 8 Francesco Frassinelli (frafra) 2012-12-25 15:26:14 UTC
*I tried to run it as user and root

As you can see:

# export users=('/root' '/home/frafra')
# for user in ${users[@]} ; do grep style= $user/.config/Trolltech.conf; done
style=Oxygen
style=Oxygen

Comment 9 Kevin Kofler 2012-12-25 16:41:39 UTC
Are you sure those lodevbasis4.0 RPMs even have the KDE NWF (Native Widget Framework) compiled in? "kde-integration" can mean several things, e.g. file dialogs only or icons only, or it might even be a dummy package.

And does liveusb-creator look better now, after using qtconfig-qt4?

Comment 10 Francesco Frassinelli (frafra) 2012-12-25 17:03:23 UTC
I don't know, but kde-integration adds a single file:

# ldd /opt/lodev4.0/program/kdebe1.uno.so
        linux-vdso.so.1 =>  (0x00007fffdd1ff000)
        libkio.so.4 => not found
        libkdeui.so.4 => not found
        libkdecore.so.4 => not found
        libqt-mt.so.3 => not found
        libuno_cppu.so.3 => /opt/lodev4.0/program/../ure-link/lib/libuno_cppu.so.3 (0x00007f42c7781000)
        libuno_cppuhelpergcc3.so.3 => /opt/lodev4.0/program/../ure-link/lib/libuno_cppuhelpergcc3.so.3 (0x00007f42c74b4000)
        libuno_sal.so.3 => /opt/lodev4.0/program/../ure-link/lib/libuno_sal.so.3 (0x00007f42c7254000)
        libstdc++.so.6 => /lib64/libstdc++.so.6 (0x00007f42c6f50000)
        libm.so.6 => /lib64/libm.so.6 (0x00007f42c6c4f000)
        libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f42c6a39000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f42c6680000)
        libuno_salhelpergcc3.so.3 => /opt/lodev4.0/program/../ure-link/lib/libuno_salhelpergcc3.so.3 (0x00007f42c6478000)
        libreg.so.3 => /opt/lodev4.0/program/../ure-link/lib/libreg.so.3 (0x00007f42c625c000)
        libxmlreader.so => /opt/lodev4.0/program/../ure-link/lib/libxmlreader.so (0x00007f42c604e000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f42c5e32000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007f42c5c2e000)
        /lib64/ld-linux-x86-64.so.2 (0x000000335f400000)
        libstore.so.3 => /opt/lodev4.0/program/../ure-link/lib/libstore.so.3 (0x00007f42c5a0e000)

liveusb-creator looks ugly, no change here.

Comment 11 Francesco Frassinelli (frafra) 2012-12-25 17:29:58 UTC
kde-integration seems something related with KDE 3. I removed it, and nothing changes: ugly graphics and good integration with oxygen icons.

Comment 12 Kevin Kofler 2012-12-25 17:51:15 UTC
Ugh, that's KDE 3 integration, totally obsolete and useless.

So you don't have the KDE 4 NWF installed, that's why your LibreOffice isn't themed properly.

Comment 13 Kevin Kofler 2012-12-25 17:52:02 UTC
No idea what's wrong with liveusb-creator though, that sounds like a separate bug.

Comment 14 Francesco Frassinelli (frafra) 2012-12-25 18:57:50 UTC
liveusb-creator bug (new informations here): https://bugzilla.redhat.com/show_bug.cgi?id=890213

LibreOffice bug: https://bugs.freedesktop.org/show_bug.cgi?id=58756


Note You need to log in before you can comment on or make changes to this bug.