This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 890325 - Horizon doesn't enable user to create network when nova network is used
Horizon doesn't enable user to create network when nova network is used
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity medium
: beta
: 4.0
Assigned To: Julie Pichon
Ami Jeain
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-26 07:23 EST by Ofer Blaut
Modified: 2016-04-26 15:15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-03 16:01:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ofer Blaut 2012-12-26 07:23:03 EST
Description of problem:

User can't create nova network via horizon , while he can do it using nova  CLI and horizon with Quantum  

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. connect to horizon with only nova-network installed 
2. try to create network 
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Matthias Runge 2013-01-11 06:17:18 EST
I can't reproduce this with openstack-django-horizon-2012.2.1 . Could you please report output the version of openstack-dashboard?
Comment 3 Ofer Blaut 2013-01-13 05:44:58 EST
Version : 

python-django-horizon-2012.2.1-2.el6ost.noarch
openstack-nova-network-2012.2.2-1.el6ost.noarch

using RHEL 6.4
Comment 4 Julie Pichon 2013-02-05 11:08:37 EST
According to the docs, in Folsom, the administrator must use the "nova-manage create-network" command to create a network -> http://docs.openstack.org/folsom/openstack-compute/admin/content/configuring-networking-on-the-compute-node.html. It's not possible to create networks using the client libraries on the CLI (even as a keystone admin), therefore it's not possible to expose it in Horizon either.

It looks like APIs to do so were added later in Grizzly: https://blueprints.launchpad.net/nova/+spec/apis-for-nova-manage, https://blueprints.launchpad.net/nova/+spec/tenant-networks. They appear to involve significant changes in Nova and novaclient.
Comment 5 Julie Pichon 2013-06-24 07:14:41 EDT
Nova-network is on its way to being deprecated, perhaps as early as the Havana cycle:

https://blueprints.launchpad.net/nova/+spec/deprecate-nova-network

I'm not sure if it makes sense to spend effort surfacing nova-network capabilities to the dashboard, when they will be removed soon.

Note You need to log in before you can comment on or make changes to this bug.